Last Comment Bug 618660 - Tracking Bug for AIX 5L port of Firefox 3.6 branch
: Tracking Bug for AIX 5L port of Firefox 3.6 branch
Status: RESOLVED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Tracking (show other bugs)
: 1.9.2 Branch
: PowerPC AIX
: -- trivial (vote)
: ---
Assigned To: Uli Link (:ul-mcamafia)
: chris hofmann
Mentors:
Depends on: 501082 526436 526446 526450 535942 545634 617272 618701 622258 623478 623504 623520 650474
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-12 02:37 PST by Uli Link (:ul-mcamafia)
Modified: 2016-07-15 12:13 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Used mozconfig file (542 bytes, text/plain)
2010-12-12 03:12 PST, Uli Link (:ul-mcamafia)
no flags Details

Description Uli Link (:ul-mcamafia) 2010-12-12 02:37:33 PST
Tracking bug
Comment 1 Uli Link (:ul-mcamafia) 2010-12-12 03:12:01 PST
Created attachment 497125 [details]
Used mozconfig file
Comment 2 Uli Link (:ul-mcamafia) 2010-12-12 09:36:43 PST
Have successfully build Firefox 3.6.13 on AIX 5.3TL11 with IBM XLC/C++ 9.0 compiler and bugs in this tracking bug.
Comment 3 Uli Link (:ul-mcamafia) 2010-12-31 04:47:01 PST
Bug# 622258 is for further backporting to AIX 5.1 where IBM XLC8 is the last supported compiler release.
Comment 4 Uli Link (:ul-mcamafia) 2011-01-05 15:58:36 PST
Minimum compiler versions:
Branch 1.9.1 compiles with VisualAge6 with some additional trivial patches and with XLC/C++ 7 Jul07 fixpack without additional patches on AIX 5.3

Branch 1.9.2 compiles with --disable-accessibility and the patch from bug# 622258 with IBM XLC/C++8 Jul07 fixpack or needs XLC/C++ 9.

Branch 2.0 will need XLC/C++ 9 or newer, not ready yet.
Comment 5 Uli Link (:ul-mcamafia) 2012-01-11 10:28:24 PST
branch 1.9.2 will also build AIX 64bit when updating the bundled libffi to version 3.0.10.
No other patches are needed when using XLC/C++ 9.0 or newer

Note You need to log in before you can comment on or make changes to this bug.