Closed Bug 618737 Opened 9 years ago Closed 7 years ago

The <video> element develops a tabindex attribute out of nowhere

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 839378

People

(Reporter: hsivonen, Unassigned)

References

()

Details

Step to reproduce:
 1) Load http://software.hixie.ch/utilities/js/live-dom-viewer/saved/736

Actual results:
The video gets a tabindex attribute in the DOM even though there's no attribute in the source.

Expected results:
Expected not the have a tabindex attribute in the DOM when there's no attribute in the source.
Summary: The <video> elements develops a tabindex attribute out of nowhere → The <video> element develops a tabindex attribute out of nowhere
Presumably from here:

http://hg.mozilla.org/mozilla-central/file/8fba5ba58911/toolkit/content/widgets/videocontrols.xml#l953

Can we fix by changing the C++ IsFocusable impl here instead?
Yeah, videocontrols.xml does this, it's the best solution I could come up with (see bug 486899 comment 20) but obviously isn't ideal.
Affects selections. Here's another testcase, if its helpful. http://jsfiddle.net/timmywil/6bHfp/
Duping forward to bug 839378, since that has a fix.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839378
You need to log in before you can comment on or make changes to this bug.