video controls should not modify page DOM

RESOLVED FIXED in mozilla21

Status

()

Toolkit
Video/Audio Controls
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

unspecified
mozilla21
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

videocontrols.xml has:
                    // Make the <video> element keyboard accessible.
                    this.video.setAttribute("tabindex", 0);

This is bad. We should not be modifying the DOM visible to the page. We need to find another way to do this.

Neil: Is there a better way to do this?

Comment 1

5 years ago
You need to override nsIContent::IsHTMLFocusable for the video element.
Created attachment 711952 [details] [diff] [review]
Don't modify the page DOM from videocontrols
Assignee: nobody → roc
Attachment #711952 - Flags: review?
Duplicate of this bug: 618737
Attachment #711952 - Flags: review? → review?(enndeakin)

Updated

5 years ago
Attachment #711952 - Flags: review?(enndeakin) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/80df535bf5e6
https://hg.mozilla.org/mozilla-central/rev/80df535bf5e6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.