Android release updates don't seem to be working

VERIFIED FIXED

Status

Release Engineering
General
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: aki, Assigned: aki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [updates])

(Assignee)

Description

8 years ago
https://aus2.mozilla.org/update/4/Fennec/4.0b2/20101103123628/Android_arm-eabi-gcc3/en-US/beta-cck-test/Linux%202.6.32.9-27220-g328f560/default/default/2.0b7pre/update.xml?force=1

gives a blank bit of xml.

bash-3.2$ pwd
/opt/aus2/incoming/3/Fennec/4.0b2/Android_arm-eabi-gcc3/20101103123628/en-US/beta-cck-test
bash-3.2$ ls -al
total 8
drwxr-xr-x 2 cltbld users 4096 Dec 15 12:37 .
drwxr-xr-x 3 cltbld users 4096 Nov  3 12:53 ..
lrwxrwxrwx 1 cltbld users   54 Dec 14 21:46 complete.txt -> /opt/aus2/incoming/3/Fennec/en-US/latest-beta-cck-test
-rw-r--r-- 1 cltbld users    0 Nov  3 12:56 partial.txt
bash-3.2$ cat complete.txt 
version=1
type=complete
url=http://stage.mozilla.org/pub/mozilla.org/mobile/candidates/4.0b3-candidates/build1/android-r7/en-US/fennec-4.0b3.en-US.eabi-arm.apk
hashFunction=sha512
hashValue=e2a152cdf33d538b3ed2a11c15031a59a14c52b1c422242efb5dba8fc405449f321b69657e80bbc71b876c3d3311d5820da33f1eefab3870c42b37535779674d
size=12409337
build=20101214200830
appv=4.0b3
extv=4.0b3
(Assignee)

Comment 1

8 years ago
Haven't yet narrowed this down between me doing something wrong and something broken on aus2.

I did try generating a bogus 4.0b1 update url
https://aus2.mozilla.org/update/4/Fennec/4.0b1/20101006203925/Android_arm-eabi-gcc3/en-US/beta/Linux%202.6.32.9-27220-g328f560/default/default/2.0b7pre/update.xml?force=1

(basically changing the version and buildid, using what should be the live beta snippet for 4.0b1) and that is also giving me an empty update.
As rhelmer points out, it works if you s#https://aus2#http://aus2-staging#, assuming 4.0b1 is supposed to be pointing at b2. I updated aus2-staging.m.o so that it was using the same code that aus2.m.o has, and it still returns data. (We had rev 1.24 of xml/inc/patch.class.php and rev 1.08 of xml/inc/config-dist.php prior to updating the code on aus2-staging).

I've tried touching aus2-staging:/opt/aus2/incoming/3 to try to rule out NFS caching (that's what we do in pushsnip for Firefox) and that didn't help. Don't have any more ideas on what could be different between the two.
Oh, it'll be that you've used an absolute symlink instead of a relative one. You can't assume that the data is mounted at the same place on the machines behind aus2.m.o.

Updated

8 years ago
Duplicate of this bug: 619484

Comment 5

8 years ago
if its any help, here are more logs from the error console:

AUS:SVC Checker:getUpdateURL - update URL:
https://aus2.mozilla.org/update/4/Fennec/4.0b2/20101103123628/Android_arm-eabi-gcc3/en-US/beta-cck-test/Linux%202.6.32.9-27220-g328f560/default/default/2.0b7pre/update.xml?force=1

AUS:SVC Checker:checkForUpdates - sending request to:
https://aus2.mozilla.org/update/4/Fennec/4.0b2/20101103123628/Android_arm-eabi-gcc3/en-US/beta-cck-test/Linux%202.6.32.9-27220-g328f560/default/default/2.0b7pre/update.xml?force=1

AUS:SVC Checker:onLoad - request completed downloading document

AUS:SVC Checker:onLoad - number of updates available: 0
tracking-fennec: --- → ?
(Assignee)

Comment 6

8 years ago
(In reply to comment #3)
> Oh, it'll be that you've used an absolute symlink instead of a relative one.
> You can't assume that the data is mounted at the same place on the machines
> behind aus2.m.o.

...aaaaand Nick is absolutely correct. AGAIN. Do you have to keep doing that? :)

in /opt/aus2/incoming/3/Fennec/4.0b2/Android_arm-eabi-gcc3
for i in */*/beta-cck-test ; do   echo $i; ln -s ../../../../../multi/latest-beta-cck-test $i/complete.txt; done

and https://aus2.mozilla.org/update/4/Fennec/4.0b2/20101103123628/Android_arm-eabi-gcc3/en-US/beta-cck-test/Linux%202.6.32.9-27220-g328f560/default/default/2.0b7pre/update.xml?force=1 now gives me update xml.
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 7

8 years ago
Updater is working for 4.0b2 -> 4.0b3. I was able to download and install beta 3.

Unforutnately it still fails for 4.0b1 -> 4.0b3.   Error console is showing these warnings:

http://img130.imageshack.us/i/updater40b1.png/

(sorry for the external screenshot...there's no way to copy/paste on fennec 4.0b1)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

8 years ago
I think I just missed in removing some of the softlinks before re-softlinking.
4.0b1->4.0b3 now works for Tony.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Comment 9

8 years ago
yay, its all working fine and dandy.   Verified fix for updating from 4.0b1->4.0b3
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.