Closed Bug 620103 Opened 12 years ago Closed 12 years ago

crash [@ nsInvalidPluginTag::~nsInvalidPluginTag() ] [@ nsInvalidPluginTag::Release() ] [@ nsInvalidPluginTag::`scalar deleting destructor''(unsigned int) ] on exit browser , high memory usage and performance lag when toggle enable/disable plug-ins

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 620114
mozilla2.0

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: crash, perf, regression)

Crash Data

Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101217 Firefox/4.0b9pre ID:20101217030324

I have encountered to crash on exit and performance lag when I test bug 617076.
And I found reproducible STR.

bp-7adbfc4e-5337-4bdd-a76f-53f072101218
bp-4b32a1aa-e29e-4e2b-b4a6-4770e2101218
bp-b1a05543-18b2-4a3b-97a1-d69772101218
bp-c883c428-cfe2-404c-9c39-447c92101218
bp-d00900ac-e00a-4ef4-b0df-4b5d62101218

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile + several plug-ins
2. Open "Add-ons Manager" (Ctrl+Shift+A)
3. Open "New Tab" (Ctrl+N)
4. Switch "Add-ons Manager" Tab

5. Select "Appearance" , "Extensions" pane
6. Switch "New Tab" tab
7. Switch "Add-ons Manager" Tab and select "Plug-ins" pane

8. repeat step5-7 at least 10 times

9. Try to toggle enable/disable several plug-ins. and Watch Memory usage in TaskManager

10. Repeat step 9 at least 5 times

11. Quit Browser (Alt , F, x)


Actual Results:
*In step 10:
 Memory usage is significantly increased by toggle plug-ins. 
 It takes time to toggle plug-ins. it is performance lag.
*After Step 11:
 Browser crashes with crash reports.

Expected Results:
 Should not increase memory usage.
 Should not encounter performance lag.
 Should not crash.
In addition to comment #0,
You may need repeat step 8 and 10.

Regression window(cached hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/2a75c2355ae9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101209 Firefox/4.0b8pre ID:20101210100952
Fails:
http://hg.mozilla.org/mozilla-central/rev/b48addc64c2f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101210 Firefox/4.0b8pre ID:20101210102726
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2a75c2355ae9&tochange=b48addc64c2f
Blocks: 616271
blocking2.0: --- → ?
Summary: crash [@ nsInvalidPluginTag::~nsInvalidPluginTag() ] , high memory usage and performance lag → crash [@ nsInvalidPluginTag::~nsInvalidPluginTag() ] on exit browser , high memory usage and performance lag when toggle enable/disable plug-ins
Summary: crash [@ nsInvalidPluginTag::~nsInvalidPluginTag() ] on exit browser , high memory usage and performance lag when toggle enable/disable plug-ins → crash [@ nsInvalidPluginTag::~nsInvalidPluginTag() ] [@ nsInvalidPluginTag::Release() ] [@ nsInvalidPluginTag::`scalar deleting destructor''(unsigned int) ] on exit browser , high memory usage and performance lag when toggle enable/disable plug-ins
And on Step9, The following alert dialog pops up.
>A script on this page may be busy, or it may have stopped responding. You can stop
>the script now, or you can continue to see if the script will complete.
>
>Script: resource://gre/modules/PluginProvider.jsm:159

Line 159 is as marked >>

      if (aTags[0].disabled == aVal)
        return;

      aTags.forEach(function(aTag) {
>>      aTag.disabled = aVal;
      });
      AddonManagerPrivate.callAddonListeners(aVal ? "onDisabling" : "onEnabling", this, false);
(In reply to comment #3)
> can you try to reproduce it with
> http://stage.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/tglek@mozilla.com-3527792a019f/try-w32/firefox-4.0b9pre.en-US.win32.zip
> ?

The tryserver build does not crash.(I tried STR 5 times)
Thanks, looks like it's a different manifestation of 620114.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 620114
blocking2.0: ? → ---
No longer blocks: 616271
Blocks: 616271
Crash Signature: [@ nsInvalidPluginTag::~nsInvalidPluginTag() ] [@ nsInvalidPluginTag::Release() ] [@ nsInvalidPluginTag::`scalar deleting destructor''(unsigned int) ]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.