File size of pluginreg.dat increases steadily when I toggle enable/disable plug-ins

RESOLVED FIXED in mozilla2.0

Status

()

Core
Plug-ins
--
critical
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Alice0775 White, Assigned: Josh Aas)

Tracking

({perf, regression})

Trunk
mozilla2.0
x86
Windows 7
perf, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101217
Firefox/4.0b9pre ID:20101217030324
And
Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre ID:20101218030347

This may be related to Bug 620103.

File size of pluginreg.dat increases steadily when I toggle enable/disable plug-ins.

*Uninstall/Re-install Silverlight does not help.
*Silverlight plug-in works well.

In pluginreg.dat, The same lines increase.
[INVALID]
c:\Program Files\Microsoft Silverlight\4.0.51204.0\npctrlui.dll|$
1291395852000|$
c:\Program Files\Microsoft Silverlight\4.0.51204.0\npctrlui.dll|$
1291395852000|$
.
.
.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile + Silverlight and other plug-ins
2. Open Add-ons Manager, and select "Plug-ins" pane
3. Toggle enable/disable any plug-ins

Actual Results:
File size of pluginreg.dat increases steadily.

Expected Results:
File size of pluginreg.dat should not increase.

Regression window(cached hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/2a75c2355ae9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101209
Firefox/4.0b8pre ID:20101210100952
Fails:
http://hg.mozilla.org/mozilla-central/rev/b48addc64c2f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101210
Firefox/4.0b8pre ID:20101210102726
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2a75c2355ae9&tochange=b48addc64c2f
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
(Assignee)

Updated

7 years ago
blocking2.0: ? → beta9+
(Assignee)

Updated

7 years ago
Assignee: nobody → joshmoz

Comment 1

7 years ago
Created attachment 498865 [details] [diff] [review]
fix

This may fix the crasher too
Attachment #498865 - Flags: review?(joshmoz)
(Assignee)

Updated

7 years ago
Attachment #498865 - Flags: review?(joshmoz) → review+

Comment 2

7 years ago
http://hg.mozilla.org/mozilla-central/rev/ed37d1bcaea4
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Duplicate of this bug: 620103

Updated

7 years ago
Duplicate of this bug: 622449

Comment 5

7 years ago
As per today's meeting, beta 9 will be a time-based release. Marking these all betaN+. Please move it back to beta9+ if  you believe it MUST be in the next beta (ie: trunk is in an unshippable state without this)
blocking2.0: beta9+ → betaN+

Updated

7 years ago
No longer blocks: 616271

Comment 6

7 years ago
i would hope this would be fixed in beta 9 considering it can hang and crash firefox.

Comment 7

7 years ago
(In reply to comment #6)
> i would hope this would be fixed in beta 9 considering it can hang and crash
> firefox.

it's fixed. Christian Legnitto's script went crazy.

Comment 8

7 years ago
ah, be careful with those scripts, last thing we want is skynet going live. :)
Blocks: 616271
You need to log in before you can comment on or make changes to this bug.