Last Comment Bug 620138 - Toolbar corner not rounded when using in-content UI like add-on manager
: Toolbar corner not rounded when using in-content UI like add-on manager
Status: VERIFIED FIXED
: ux-consistency
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All Windows 7
: -- trivial (vote)
: Firefox 8
Assigned To: Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
:
Mentors:
: 617914 (view as bug list)
Depends on:
Blocks: 571970 589259
  Show dependency treegraph
 
Reported: 2010-12-18 11:04 PST by redsign
Modified: 2011-09-08 01:39 PDT (History)
10 users (show)
bmcbride: in‑testsuite-
bmcbride: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Comparison of the outside corners with and without in-content UI (43.25 KB, image/png)
2010-12-18 11:11 PST, redsign
no flags Details
Patch v1 (3.30 KB, patch)
2011-06-22 20:20 PDT, Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
dao+bmo: review+
Details | Diff | Review

Description redsign 2010-12-18 11:04:27 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre

The corners of the toolbar are rounded since the landing of Bug 589259 - top outside corners of navigation toolbar need border radius. The corners become rectangular again when viewing in-content UI like the new add-on manager. 

Reproducible: Always

Steps to Reproduce:
1.Open the add-on manager

Actual Results:  
The top outside corners of the browser chrome become rectangular.

Expected Results:  
The corners should be rounded as before.
Comment 1 redsign 2010-12-18 11:11:48 PST
Created attachment 498529 [details]
Comparison of the outside corners with and without in-content UI

Outside corner with a tab showing a regular website on the left and with showing the add-on manager on the right.
Comment 2 Ed Morley [:emorley] 2010-12-18 11:25:42 PST
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101217 Firefox/4.0b9pre ID:20101217030324
Comment 3 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-06-22 20:20:46 PDT
Created attachment 541274 [details] [diff] [review]
Patch v1

Also works pretty well with the patch with bug 644721 (aside from the bitrot).
Comment 4 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-08 03:13:47 PDT
https://hg.mozilla.org/integration/fx-team/rev/9c3ea24a7bff
Comment 5 Tim Taubert [:ttaubert] 2011-08-09 09:08:14 PDT
http://hg.mozilla.org/mozilla-central/rev/9c3ea24a7bff
Comment 6 Henrik Skupin (:whimboo) 2011-08-11 09:06:18 PDT
Vlad, could you please verify this bug on Win7? Currently I do not have access to such a machine. Thanks.
Comment 8 Henrik Skupin (:whimboo) 2011-08-15 06:11:30 PDT
Bogas, does it look the same with a Nightly build for you? Not sure if there have been landed any other patches on the UX branch which could affect this.
Comment 9 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-08-15 18:25:23 PDT
Note that the UX branch contains unfinished patches - such as the patch from bug 644721, which will need updating to take into account the fix for this bug. Part of the bitrot I mentioned in comment 3 is taking into account the CSS changes made in this bug.
Comment 10 Trif Andrei-Alin[:AlinT] 2011-08-26 05:12:51 PDT
Mozilla/5.0 (Windows NT 6.1; rv:8.0a2) Gecko/20110825 Firefox/8.0a2

It has been fixed on latest Aurora and Nightly.
Setting resolution to Verified Fixed.
Thanks.
Comment 11 Dão Gottwald [:dao] 2011-09-08 01:39:06 PDT
*** Bug 617914 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.