Some devices are not seeing Firefox in the Android market

VERIFIED WORKSFORME

Status

Fennec Graveyard
General
VERIFIED WORKSFORME
7 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Bug Flags:
in-litmus ?

Details

(Whiteboard: [4.0b3])

(Reporter)

Description

7 years ago
Starting a bug to track this.   There are several mozilla android users on different phones and OS's that are reporting that they cannot search for the Mozilla Firefox Web Browser in the Android Market.    They have tried typing in search keys like "mozilla", "firefox", but nothing appears.

Some environments reported:
- Nexus One, Android 2.2, ATT/3G:  Search Found (tchung)
- HTC Evo 4G, Android 2.2, Sprint/3G: Search Found (marcia)
- Samsung Captivate, Android 2.1, wifi: Search *NOT*( found (stuart)
- Samsung Vibrant, Android 2.1, T-mobile/3G: Search NOT found (aakash)
- Samsung Epic, Android 2.1, Sprint/3G: Search *NOT* found (mevans)
- Samsung Captivate, Android 2.1, ATT/3G: Search found, downloaded, no notification shown, then search *NOT* found (abillings)

Repro:
1) on a Android 2.1 or 2.2 device, go to Android Market
2) search field, type in "mozilla" or "firefox"
3) some devices cannot find the Mozilla Firefox Web Browser app.

Expected:
- all devices should find Mozilla Firefox Web Browser

ActuaL:
- several devices above are reported that dont find the search
I tested this on my AT&T Captivate running Android 2.1. The phone is rooted and the bit flipped to install third party apps. Otherwise, it is pretty clean.

I had a Fennec 4.0b3pre build installed.

I went to the Market, did a search on 'firefox' and found the 4.0b3 app in the list. I told Market to install it. It prompted me with what the app would do and I agreed. At that point, I received *NO* notification that it was downloading or ever completed downloading. Firefox does not show up as an installed app on the device. Searching on Market on 'firefox' or 'mozilla' no longer shows Firefox as an available application. 

So, I don't have the official build from Market. It never downloaded and it no long shows up in searches.

Comment 2

7 years ago
Seeing the same thing on my captivate. No prior Firefox/Fennec installs on the system. Here's what happened to me. 

I went to the Market, searched for Firefox, found it and started the install. The download completed but never triggered the install. I clicked on the completed download in the android notification area and it disappeared with no install. After that, returning to the market showed no Firefox available. 

I'm guessing that the system thinks it's still in the middle of the installation so doesn't list it as available in the market or something like that.

Comment 3

7 years ago
also worth adding that I could NOT reproduce this problem with my nexus one running android 2.2.  Both systems were being used with wi-fi only.

Comment 4

7 years ago
I reset my samsung captivate and tried again and the install completed. There was an abnormally long pause between the download complete and the install complete though.
OS: Mac OS X → Android
Hardware: x86 → All
"Reset" it how, Asa?

Comment 6

7 years ago
Al, factory reset under Settings->Privacy.
There are some reports this is related to the most recent update to the Market app.  If you open the "Manage Application" settings and uninstall the update, does the problem still appear?

On devices without GPS, this might also be caused by bug 621262.  (All of the Samsung devices listed above do have GPS and should not be affected by that, but maybe the OS or the Market app does not report the GPS capability correctly.)
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b4+

Comment 8

7 years ago
happens on my rooted stock 2.1 Samsung Vibrant.
Can't find the application and I'd rather not reset. >.>
Flags: in-litmus?
Whiteboard: [4.0b3]
My friend confirms that uninstalling the market updates on his Captivate fixes it such that Firefox shows up in the market.

Comment 10

7 years ago
I've completely restored my samsung captivate. no root, no su, no nothing.  First attempt at installing from the store failed.  The install downloaded but never triggered the actual install.  My Notifications panel says "Mozilla Firefox Web Browser Download complete" and then just sits there. I let it sit for several minutes to see if it would kick off the actual install but it doesn't. If I click on the downloaded Firefox in the Notification panel, it just clears it from the Notification panel. Now it doesn't show up in the store. 

I believe that what's happening is that the download is completed and sitting on the system so the Store app thinks it's still in the install process and so doesn't show the listing in the Store listings.

Is there any way to locate the Store App's download location and manually kick off an install from the downloaded package? Alternatively, is there any way to clear a "partial" install like this from the Store App.
We put a test no-thumb build into the market and it showed up on the affected devices. That, combined with the fact that this issue goes away when you uninstall the market updates leads me to conclude that there is a bug in one of the market updates with how they're detecting the CPU version on these devices.

Comment 12

7 years ago
worse, our website points at the market, so anyone going to mozilla.com/m and who wants to download firefox (perhaps because they can't find it in the store) gets a useless error message.  Currently no way to get Fx on my stock vibrant, unless I run nightlies.
Justin, you can uninstall the apparently broken market updates. Ask on #mobile if you need help.
that doesn't scale.  I think we might want to take down the website link until this bug is sorted out.

Updated

7 years ago
tracking-fennec: 2.0b4+ → 2.0next+

Updated

7 years ago
tracking-fennec: 2.0next+ → 2.0b4+
(Reporter)

Comment 15

7 years ago
do we haven an update on this bug?
There are reports that this was fixed in the market. If you have an affected device, please re-test.

Comment 17

7 years ago
It is now appearing on an Evo that it was previously not appearing on, as well as a Captivate and a Vibrant.  I have seen another Vibrant that is still not showing.  Perhaps a fix is being rolled out?
Still not showing on Galaxy S.
(Reporter)

Comment 19

7 years ago
Matt's Samsung Epic is also still not showing it.

Comment 20

7 years ago
not showing up on my verizon galaxy S and download from the website still doesn't work.  Probably all verizon phones can't download...
(Reporter)

Comment 21

7 years ago
(In reply to comment #20)
> not showing up on my verizon galaxy S and download from the website still
> doesn't work.  Probably all verizon phones can't download...

fwiw, Matt Evans Epic is on Sprint.
No change on my AT&T Captivate. I can't find Firefox in the Market (ever since my failed install).

Comment 23

7 years ago
now working just fine on my AT&T Samsung Galaxy S. (tested on a fully restored handset)

Comment 24

7 years ago
My theory is that for the case of "missing after failed install" (like I was experiencing, and it sounds like Al too) you won't get Firefox back in the market until you get a fix to the marketplace app. I think it thinks it succeeded in installing Firefox during that failed first attempt and that's why Firefox isn't showing up as available in the marketplace. I just reset my phone and that did the trick.
So I have to reset my phone and lose any installed apps to resolve this issue? Is that correct?
(In reply to comment #25)
> So I have to reset my phone and lose any installed apps to resolve this issue?
> Is that correct?

Some people are able to download Firefox from the Market after uninstalling the update to the Market app.  This may be a temporary fix, however, as the Market app will update itself again, silently.

We're trying to see if a new Market is fixing this issue.  The last Market update took a few weeks to be rolled out to all users.

Comment 27

7 years ago
Same problem on a brand new HTC wildfire.
(In reply to comment #27)
> Same problem on a brand new HTC wildfire.

The HTC Wildfire is not compatible with our official beta releases.  See https://wiki.mozilla.org/Mobile/Platforms/Android for details.

Comment 29

7 years ago
This appears to now be showing up on the Fascinates, Vibrants, Captivates, Evos, etc that it was not previously showing up on (that it was intended to show up on).  Marking this bug FIXED (by Google in the market)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 30

7 years ago
verified on my phone.
Still fails on Samsung Epic.
OS: Android → All
reopening based on matt's comments.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Given the back and forth, and the influx of people confirming that they can see Firefox in the market on their phones, I am removing blocking from this bug.

If this is still a wide scale problem, as it once was, we can adjust blocking.
tracking-fennec: 2.0b4+ → ---
Verified working on my AT&T Captivate now.
Working now on Samsung Epic!
ok, closing
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 37

7 years ago
yess... finally!
Status: RESOLVED → VERIFIED

Comment 38

7 years ago
I have been trying to get firefox for weeks on my Sony Xperia 10 and I have this same problem.  It says on the mozzilla website my phone is supported but it does not appear in a market search and the link from the firefox website says object not found.  Tried uninstalling market updates, no difference.  Help!

Thanks
(Reporter)

Comment 39

7 years ago
(In reply to comment #38)
> I have been trying to get firefox for weeks on my Sony Xperia 10 and I have
> this same problem.  It says on the mozzilla website my phone is supported but
> it does not appear in a market search and the link from the firefox website
> says object not found.  Tried uninstalling market updates, no difference. 
> Help!
> 
> Thanks

do u have android 2.0 and higher running? I believe the x10 comes with android 1.6 as default, and that's not supported for firefox.
You need to log in before you can comment on or make changes to this bug.