Last Comment Bug 621066 - [regression] Panning about: pages always makes sidebar disappear
: [regression] Panning about: pages always makes sidebar disappear
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: Panning/Zooming (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
:
Mentors:
Depends on:
Blocks: 598391
  Show dependency treegraph
 
Reported: 2010-12-22 15:25 PST by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2011-07-14 21:31 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (812 bytes, patch)
2011-02-11 10:36 PST, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
mbrubeck: review+
Details | Diff | Splinter Review

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2010-12-22 15:25:09 PST
When you pan around in pages like about:firefox and you have one of the sidebars open (for example the tab sidebar), the sidebar and url bar suddenly disappear after you've panned after a certain threshold.
I see this happening on Android and Maemo.

I see this only happening on about: pages. On regular pages, this works as expected.

Maybe this is related to bug 597081?
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2010-12-22 15:27:37 PST
Also happens when reloading the about:* page.
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-01-03 09:36:14 PST
Steps to reproduce:
- Go to about:firefox
- Pan to the right to open the left sidebar
- Pan upwards to scroll down

Expected result:
- The left sidebar should stay open

Actual result:
- The left sidebar is suddenly closed, after scrolling down for a while.
Comment 3 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-01-04 02:42:12 PST
I know what you mean because I've seen this bug a few times, but for some reason I can't reproduce it today.
Comment 4 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-01-04 04:04:27 PST
I can still see it happening on 2011-01-03 builds on Android and Maemo.
Comment 5 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-02-11 10:36:58 PST
Created attachment 511771 [details] [diff] [review]
Patch

This is a regression from bug 598391. With this patch the testcase still works for me and I don't the wrong sidebars/urlbar behavior you were referring to.
Comment 6 Matt Brubeck (:mbrubeck) 2011-02-11 10:41:21 PST
Comment on attachment 511771 [details] [diff] [review]
Patch

>+          if (position.x)
>+            this.hideSidebars();
>+
>+          if (position.y != 0)
>+            this.hideTitlebar();

Nit: Please change the "if" tests to match (add "!= 0" to both, or remove it from both).
Comment 7 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2011-02-11 11:23:00 PST
http://hg.mozilla.org/mobile-browser/rev/c4d737c1137e
Comment 8 Anna (Waverley) 2011-05-26 06:24:37 PDT
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110526 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)

Note You need to log in before you can comment on or make changes to this bug.