Closed Bug 621081 Opened 9 years ago Closed 9 years ago

New feed discovery icon is never shown in disabled state on Linux

Categories

(Firefox :: Theme, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b9

People

(Reporter: pascalc, Assigned: tymerkaev)

References

Details

Attachments

(4 files)

The new icon for Web feed for Linux introduced in bug 596731 has a couple of issues:

- it doesn't have any visual disabled state when there is no feed in the page (contrary to Windows and Mac) which makes it useless on Linux and not light visually
- the image used is no longer the same as in 3.6, it uses the big square one which looks 'bulky' compared to icons we usually use in the toolbar menu. We should use the one 3.6 had and that we also use in the bookmarks menu

I am going to attach a patch for gnomestripe.css that fixes those issues (note that it is the first time that I do a patch for our software, I hope I did it correctly ;) )

I compiled Minefield with this patch on Ubuntu 10.10 and it works and looks good on a variety of themes I tried (Radiance, Clearlook, Ambiance, Hight contrast...).

I am going to also attach before/after screenshots.
Attached image Current state
Attached image after patch
CCing a few people in front end realm, guys who should I ask a review for this patch?
Duplicate of this bug: 604972
Blocks: 596731
No longer depends on: 596731
It would probably be better to update the image in Toolbar.png instead of re-using the other image (whose size is different for large icons). Otherwise that patch looks good to me.
Current icons will be changed soon, so skip creating new icons and just set opacity for icon. I'll remove this line in bug 572484.
Attachment #499532 - Flags: review?(dao)
Attachment #499532 - Flags: review?(dao) → review+
Assignee: nobody → tymerkaev
Component: RSS Discovery and Preview → Theme
Keywords: icon
QA Contact: rss.preview → theme
Status: NEW → ASSIGNED
Pascal, feel free to file a new bug on using a different icon.

http://hg.mozilla.org/mozilla-central/rev/fb981ac88e18
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Summary: New feed discovery icon is never shown in disabled state in Linux and doesn't look so good → New feed discovery icon is never shown in disabled state on Linux
Target Milestone: --- → Firefox 4.0b9
You need to log in before you can comment on or make changes to this bug.