Enhance tryserver email threading

RESOLVED WONTFIX

Status

P5
enhancement
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tryserver])

(Reporter)

Description

8 years ago
With the number of try server emails one can get when enabling a whole bunch of tests for various architectures, I think some enhancement on email threading could be welcome, such as having the following hierarchy:
+- Try submission (the thanks for your try submission message)
  +- linux build message
     +- linux mochitest1 message
     +- linux mochitest2 message
     +- ...
  +- win32 build message
     +- test message
  +- mac build message

This could be achieved quite easily, by having the various messages use different headers, e.g.:
Try submission:
Message-Id: <tryserver-$rev@try.build.mozilla.com>

Build messages:
Message-Id: <tryserver-build-$rev@try.build.mozilla.com>
In-Reply-To: <tryserver-$rev@try.build.mozilla.com>
References: <tryserver-$rev@try.build.mozilla.com>

Test messages:
Message-Id: <tryserver-test-$rev@try.build.mozilla.com>
In-Reply-To: <tryserver-build-$rev@try.build.mozilla.com>
References: <tryserver-$rev@try.build.mozilla.com> <tryserver-build-$rev@try.build.mozilla.com>
Blocks: 572808
Priority: -- → P5
Whiteboard: [tryserver]
Duplicate of this bug: 569508

Updated

8 years ago
Duplicate of this bug: 636289
Now there are other ways to get the info on your try run: post to a bug, self-serve and you can disable emails to get less of them.  The rest I think we can leave to mail filters.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.