Closed Bug 622570 Opened 9 years ago Closed 9 years ago

Firefox button menu remains open when middle clicking a bookmark

Categories

(Firefox :: Menus, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 4.0b10
Tracking Status
blocking2.0 --- -

People

(Reporter: pocketgamer5000, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre

Firefox 4.0b9pre (3 Jan 2011):
When opening a bookmark in a new tab using the mouse middle click, the Firefox menu remains open as the new tab loads.

Reproducible: Always

Steps to Reproduce:
1. Click on Firefox button on top left
2. Hover over bookmarks
3. Middle click a website to open it in a new tab
Actual Results:  
The Firefox menu remains active despite the bookmark being loaded in a new tab and the immediate bookmarks section (of the menu) closing.

Expected Results:  
The Firefox menu should no longer be active and return focus to the main tab (while the new tab is loading).

I rated this bug as a major bug because it is a UI break in a flagship feature of Firefox 4.0
Blocks: 583386
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Version: unspecified → Trunk
I don't think this blocks, but if Alex disagrees he can renominate with rationale.
blocking2.0: ? → -
Fixed by bug 622571
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
Verified fixed with Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre

Any chance to test this automatically?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.