Closed Bug 622663 Opened 12 years ago Closed 12 years ago

Tab-modal confirm() hangs/lags browser on Wowhead, causes multiple dialogs to appear

Categories

(Toolkit :: General, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: xhva.net, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [hardblocker])

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre

With the new tab-modal confirm dialog, Wowhead's Item Comparison page now fails to function correctly when deleting an item. Two things appear to happen:
 - the browser spawns another confirm() dialog when either button is clicked.
 - the browser becomes exponentially slower with each dialog because of the multiple overlaid radial gradients in the background. This results in the browser taking a full core of CPU while displaying the Wowhead page. Switching to another tab restores performance.

The number of dialogs are finite, and clicking through them (or using the keyboard since mouse events don't seem to fire correctly when at full CPU) will eventually restore performance. You're able to see the gradient building up and fading away with each click.

Reproducible: Always

Steps to Reproduce:
1. Open this Wowhead page: http://www.wowhead.com/compare?items=56543:56555&l=85 . Two items with blue backgrounds should be shown under a grey slider control.
2. Drag one of the items into the large grey area near the bottom of the page.
3. A confirm dialog appears. Click either option, and another dialog appears. Browser performance goes progressively south.


Expected Results:  
One confirm dialog with no performance penalty.

The performance issue seems to be caused by radial gradients being slow on XP, compounded by the fact that there's multiple overlaid. Fligtar's blog uses radial gradients and has similar performance issues on my two XP machines (see http://blog.fligtar.com). Resizing the window to postage-stamp size while clicking the dialogs fixes most of the performance issue.
I can reproduce this. Wonder if bug 615186 might be related.
Status: UNCONFIRMED → NEW
Ever confirmed: true
blocking2.0: --- → ?
Version: unspecified → Trunk
Maybe bug 618856 would solve this problem too.
blocking2.0: ? → betaN+
Whiteboard: [hardblocker]
Mozilla/5.0 (Windows NT 6.0; rv:2.0b10pre) Gecko/20110112 Firefox/4.0b10pre

Can't repro either. This is probably related to bug 620145 which was fixed after the reporter's buildid. Please update to tip and reconfirm. The page doesn't trigger selection so bug 615186 doesn't seem to be related at first glance. It does seem to trigger a confirm on mouseup though, so that's probably it...
Indeed, this was fixed by bug 620145.
Status: NEW → RESOLVED
Closed: 12 years ago
Depends on: 620145
Resolution: --- → FIXED
Blocks: 625051
No longer blocks: 625051
You need to log in before you can comment on or make changes to this bug.