Last Comment Bug 622839 - Paul's Mobile Video demo is slow and creates graphic artifacts
: Paul's Mobile Video demo is slow and creates graphic artifacts
Status: RESOLVED WORKSFORME
: meta, mobile, perf
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Stuart Parmenter
:
Mentors:
http://paulrouget.com/2big/st/DEMOS/m...
Depends on: 635694 635703
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-04 08:04 PST by Paul Rouget [:paul]
Modified: 2013-11-12 06:08 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Artifacts screenshot (183.88 KB, image/png)
2011-01-04 08:04 PST, Paul Rouget [:paul]
no flags Details

Description Paul Rouget [:paul] 2011-01-04 08:04:54 PST
Created attachment 501020 [details]
Artifacts screenshot

Please ask me on IRC (paul) for the login/pwd, I'd like to keep this demo private for now.

Load this web page on Firefox4 Desktop to see the expected behavior.
In landscape mode (or window.width < 600px and landscape mode in Firefox Desktop), click on the video to display the controls.

(tested on a Nexus One)

Playing the video is extremely slow (probably 1FPS, but can be slower). It slows down the whole device.

Also, it generates graphic artifacts (see attachment).
Comment 1 Stuart Parmenter 2011-01-04 10:27:11 PST
Paul, what is the performance with GL turned on?  I see similar graphics artifacts on sites like youtube with HTML5 video.
Comment 2 Paul Rouget [:paul] 2011-01-05 03:07:44 PST
Can't test GL. When I turn it on, Fennec crashes (nightly) even for a simple "Index of" page.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-01-20 12:27:19 PST
Stuart - Do we have a "video is slow" bug? This seems like a meta bug.
Comment 4 Doug Turner (:dougt) 2011-01-25 13:07:50 PST
Bug 626344 tracks the YouTube HTML5 use case.  I am going to make this bug as a dup of that.

*** This bug has been marked as a duplicate of bug 626344 ***
Comment 5 Aakash Desai [:aakashd] 2011-02-15 09:43:39 PST
Is that really related? The youtube html5 bug is related to video not playing at all. In this bug, the video plays, but with slow performance and low stability.
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2011-02-15 12:33:33 PST
Paul, can you create some smaller test cases so we can have some actionable bugs from them.
Comment 7 Paul Rouget [:paul] 2011-02-16 08:51:07 PST
ok. Working on it right now.
Comment 8 Doug Turner (:dougt) 2011-02-16 09:03:43 PST
paul, if you don't scale/transform, does video playback work better?  I think it should.
Comment 9 Brad Lassey [:blassey] (use needinfo?) 2011-02-18 12:45:04 PST
paul will be filing bugs for individual issues, so this is a meta bug now and meta bugs don't block
Comment 10 Wayne Mery (:wsmwk, NI for questions) 2013-11-12 05:44:16 PST
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #9)
> paul will be filing bugs for individual issues, so this is a meta bug now
> and meta bugs don't block

all the blocking bugs are closed. So can someone also close this, unless it is still needed?

Note You need to log in before you can comment on or make changes to this bug.