Firefox 4.0b8 crashes on Windows XP when switching to Sogou Input Method [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] [@ SogouPy.ime@0x40e65 ] [@ SogouPy.ime@0x161ebe ] [ SogouPy.ime@0x37b85 ] [@ SogouPy.ime@0x3f075 ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: scoobidiver, Assigned: jrmuizel)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 .x+)

Details

(Whiteboard: [softblocker], crash signature)

(Reporter)

Description

8 years ago
There are new crash signatures.
It happens on Windows XP.
Combined signatures are #34 top crasher in 4.0b8 for the last week.
It is a bug similar to bug 570722 (now fixed) and bug 620790 (4.0b8).

Signature	SogouPy.ime@0x16341e
UUID	8af44613-6d2c-4ccd-89d1-4ecce2110104
Time 	2011-01-04 08:21:07.728316
Uptime	3549
Last Crash	3550 seconds (59.2 minutes) before submission
Install Age	776697 seconds (1.3 weeks) since version was first installed.
Product	Firefox
Version	4.0b8
Build ID	20101214170338
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	AuthenticAMD family 16 model 2 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address	0x8
User Comments	
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0640

Frame 	Module 	Signature [Expand] 	Source
0 	SogouPy.ime 	SogouPy.ime@0x16341e 	
1 	SogouPy.ime 	SogouPy.ime@0x163815 	
2 	user32.dll 	InternalCallWinProc 	
3 	user32.dll 	__fnINOUTLPSCROLLINFO 	
4 	user32.dll 	DispatchClientMessage 	
5 	user32.dll 	__fnINLPCREATESTRUCT 	
6 	ntdll.dll 	KiUserCallbackDispatcher 	
7 		@0xb9fffff 	
8 	user32.dll 	_CreateWindowEx 	
9 	user32.dll 	CreateWindowExW 	
10 	user32.dll 	CreateIMEUI 	
11 	user32.dll 	ImeSelectHandler 	
12 	user32.dll 	ImeWndProcWorker 	
....

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=SogouPy.ime%400x16341e&version=Firefox%3A4.0b8
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=SogouPy.ime%400x160d0e&version=Firefox%3A4.0b8
(Reporter)

Comment 1

8 years ago
> and bug 620790 (4.0b8).
Oops. Bug 620490 (4.0b8).
(Reporter)

Updated

8 years ago
Summary: Firefox 4.0b8 crashes on Windows XP [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] → Firefox 4.0b8 crashes on Windows XP [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] [@ SogouPy.ime@0x161ebe ]
(Reporter)

Comment 2

8 years ago
Still #34 top crasher in 4.0b8.

Here is a complete stack trace:
0 	SogouPy.ime 	SogouPy.ime@0x16341e 	
1 	SogouPy.ime 	SogouPy.ime@0x163815 	
2 	user32.dll 	InternalCallWinProc 	
3 	user32.dll 	GetPropW 	
4 	user32.dll 	DispatchClientMessage 	
5 	user32.dll 	__fnINLPCREATESTRUCT 	
6 	ntdll.dll 	KiUserCallbackDispatcher 	
7 	ntdll.dll 	KiUserApcDispatcher 	
8 	user32.dll 	_CreateWindowEx 	
9 	user32.dll 	CreateWindowExW 	
10 	user32.dll 	CreateIMEUI 	
11 	user32.dll 	ImeSelectHandler 	
12 	user32.dll 	ImeWndProcWorker 	
13 	user32.dll 	ImeWndProcW 	
14 	user32.dll 	InternalCallWinProc 	
15 	user32.dll 	UserCallWinProcCheckWow 	
16 	user32.dll 	SendMessageW 	
17 	user32.dll 	SendMessageW 	
18 	guard32.dll 	guard32.dll@0x1ae95 	
19 	imm32.dll 	ImmActivateLayout 	
20 	user32.dll 	ImeSystemHandler 	
21 	user32.dll 	ImeWndProcWorker 	
22 	user32.dll 	ImeWndProcW 	
23 	user32.dll 	InternalCallWinProc 	
24 	user32.dll 	UserCallWinProcCheckWow 	
25 	user32.dll 	DispatchClientMessage 	
26 	user32.dll 	__fnDWORD 	
27 	ntdll.dll 	KiUserCallbackDispatcher 	
28 	ntdll.dll 	KiUserApcDispatcher 	
29 	user32.dll 	RealDefWindowProcW 	
30 	user32.dll 	DefWindowProcW 	
31 	user32.dll 	InternalCallWinProc 	
32 	user32.dll 	UserCallWinProcCheckWow 	
33 	user32.dll 	CallWindowProcAorW 	
34 	user32.dll 	CallWindowProcW 	
35 	xul.dll 	nsWindow::WindowProcInternal 	widget/src/windows/nsWindow.cpp:4461
36 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:4408
37 	user32.dll 	InternalCallWinProc 	
38 	user32.dll 	UserCallWinProcCheckWow 	
39 	user32.dll 	DispatchMessageWorker 	
40 	user32.dll 	DispatchMessageW 	
41 	xul.dll 	nsAppShell::ProcessNextNativeEvent 	widget/src/windows/nsAppShell.cpp:335
42 	nspr4.dll 	PR_IntervalNow 	nsprpub/pr/src/misc/prinrval.c:77
43 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:333
44 	xul.dll 	nsTArray_base<nsTArrayDefaultAllocator>::ShiftData 	obj-firefox/dist/include/nsTArray-inl.h:169
45 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
46 	xul.dll 	xul.dll@0xb2aa7f
Component: Other → Widget: Win32
Product: Plugins → Core
QA Contact: other → win32
Summary: Firefox 4.0b8 crashes on Windows XP [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] [@ SogouPy.ime@0x161ebe ] → Firefox 4.0b8 crashes on Windows XP when switching to Sogou Input Method [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] [@ SogouPy.ime@0x40e65 ] [@ SogouPy.ime@0x161ebe ] [ SogouPy.ime@0x37b85 ] [@ SogouPy.ime@0x3f075 ]
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
I'm not sure who should own this. Masayuki? Lingfeng?
blocking2.0: ? → final+
Chris, can you try to reproduce this blocker?
Are these crashes happening when the Sogou Cloud Input addon is activated? Or with some other external program?
Hmm, I cannot reproduce the caresh too. We need the STR.
(Reporter)

Comment 8

8 years ago
Here are some comments in Chinese (translated from Google):
"To log in Baidu account suddenly crashes."
"Switch "Sogou input method" Crash"
"when I switch to the chinese sogou input method,the firefox is crashed.I don't know why.since I install the ffb8."
(In reply to comment #6)
> See https://bugzilla.mozilla.org/show_bug.cgi?id=570722#c2

I've installed Sogou IME and am able to input Chinese characters. I cannot reproduce a crash though.

I tried these versions:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101007 Firefox/4.0b8pre
Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre

STR would be very helpful.

This is now topcrash #204 in beta 9:
http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/4.0b9
(Reporter)

Comment 10

8 years ago
In reply to comment 9
> I cannot reproduce a crash though.
Try to use Beta 9 instead of a nightly build.

More Beta 9 reports at:
http://crash-stats.mozilla.com/query/query?product=Firefox&version=Firefox%3A4.0b9&platform=windows&branch=2.0&range_value=1&range_unit=weeks&query_search=signature&query_type=startswith&query=SogouPy.ime&build_id=&process_type=any&hang_type=any&do_query=1

With combined signatures, there are 423 crashes/week in Beta 8 and 91 crashes/week in Beta 9, so it is a virtual #37 (resp. #67) top crasher in 4.0b8 (resp. 4.0b9) for the last week.
May be this difference in ranking is due to more Sogou disabling by users as they know it is caused by it.

It happens with various versions of Sogou including 5.1.1.4954 (the latest one?)

Comment 11

8 years ago
Hmm, looking at this, it seems like the add-on is crashing while handling a Windows message.  There isn't really any of our code involved, and I don't see what we can do to fix this even if we could reproduce this.  The only fix that I can imagine here is to block the DLL, and communicate the bug back to Sogou's developers.

roc, what do you think?
You may be right, but it's possible it's a regression because it makes some assumptions (e.g. about our HWNDs) that are no longer true, and it could be useful to know what those assumptions are --- maybe we can work around it.

Have a go at reproducing it, and if you can't, move on...

Comment 13

8 years ago
lguan: could you please get someone from sogou to create an account with bugzilla?

Comment 14

8 years ago
I installed the Sogou IME software, and played with it for a while.  Firefox didn't crash while I was using it...
(Assignee)

Updated

8 years ago
Assignee: nobody → jmuizelaar
(Assignee)

Updated

8 years ago
Keywords: regressionwindow-wanted
(Assignee)

Updated

8 years ago
Depends on: 631550
(Assignee)

Comment 15

8 years ago
Looks like this started at around build 20101111042449
(Assignee)

Comment 16

8 years ago
or rather 20101111042449
(Assignee)

Comment 17

8 years ago
20101110043309 df1d1ff6b489 -> 20101111042449 0f17e5f1eb01

possible regression window:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1d1ff6b489&tochange=0f17e5f1eb01
(Assignee)

Comment 18

8 years ago
The most suspicious thing that I can see there is asynchronous plugin painting, but it's not that great of a candidate.

Comment 19

8 years ago
Kev, can you talk to Mozilla-China to see if we can get some help from the IME authors?
** PRODUCT DRIVERS PLEASE NOTE **

This bug is one of 7 automatically changed from blocking2.0:final+ to blocking2.0:.x during the endgame of Firefox 4 for the following reasons:

 - it was marked as a soft blocking issue without a requirement for beta coverage
blocking2.0: final+ → .x+
Crash Signature: [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] [@ SogouPy.ime@0x40e65 ] [@ SogouPy.ime@0x161ebe ] [@ SogouPy.ime@0x3f075 ]
(Reporter)

Comment 21

7 years ago
There have been no crashes containing SogouPy.ime in their signature for the last four weeks.
I close it as WFM.
Crash Signature: [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] [@ SogouPy.ime@0x40e65 ] [@ SogouPy.ime@0x161ebe ] [@ SogouPy.ime@0x3f075 ] → [@ SogouPy.ime@0x16341e ] [@ SogouPy.ime@0x160d0e ] [@ SogouPy.ime@0x40e65 ] [@ SogouPy.ime@0x161ebe ] [@ SogouPy.ime@0x3f075 ]
Still no Crashes (http://bit.ly/N2969i) -> closing as WFM for real :-)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.