Intermittent browser_bug553455.js | Should have seen the install fail - Got addon-progress-notification, expected addon-install-failed-notification, with or without a timeout, not Got 2 expected 1

RESOLVED FIXED in Firefox 15

Status

()

defect
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: philor, Assigned: froydnj)

Tracking

({intermittent-failure})

Trunk
mozilla17
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(firefox15 fixed, firefox16 fixed, firefox-esr10 fixed)

Details

(Whiteboard: [qa-] fails in test_localfile)

Attachments

(3 attachments, 2 obsolete attachments)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294242527.1294246844.3543.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2011/01/05 07:48:47
s: win32-slave41

TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should be only one notification
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should have seen the install fail - Got addon-progress-notification, expected addon-install-failed-notification
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should have seen the right message - Got Add-on downloading, expected This add-on could not be installed because it appears to be corrupt.
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Test part took 529ms
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should be no active installs - Got 1, expected 0
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294234863.1294239097.30706.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2011/01/05 05:41:03
s: win32-slave39

TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should be only one notification
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should have seen the install fail - Got addon-progress-notification, expected addon-install-failed-notification
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should have seen the right message - Got Add-on downloading, expected This add-on could not be installed because it appears to be corrupt.
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Test part took 565ms
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_bug553455.js | Should be no active installs - Got 1, expected 0
I'm not absolutely sure about comment 3, since it's on the new WinXP testers, where it could be XP-specific instead of a slightly different manifestation of this new thing.
Posted patch Prossible fix (obsolete) — Splinter Review
This patch will fix most of failures.

I can not reproduce this issue at least on my linux machine with this patch and the patch for bug 626998.
Attachment #506202 - Flags: review?
Attachment #506202 - Flags: review? → review?(dtownsend)
(In reply to comment #147)
> Created attachment 506202 [details] [diff] [review]
> Prossible fix
> 
> This patch will fix most of failures.
> 
> I can not reproduce this issue at least on my linux machine with this patch and
> the patch for bug 626998.

In which cases is the notification remaining open when it should have closed?
(In reply to comment #149)
> (In reply to comment #147)
> In which cases is the notification remaining open when it should have closed?

Before running test_whitelisted_install, test_corrupt_file, test_incompatible. In the middle of wait_for_notification of test_corrupt_file and test_incompatible and others.
Comment on attachment 506202 [details] [diff] [review]
Prossible fix

Instead add code to those places to wait for the notification to close before proceeding.
Attachment #506202 - Flags: review?(dtownsend) → review-
(In reply to comment #153)
> Comment on attachment 506202 [details] [diff] [review]
> Prossible fix
> 
> Instead add code to those places to wait for the notification to close before
> proceeding.

I understand what you want to do, but I did not get all of the cases which stays open the notification. So I did insert the code there.