Closed Bug 623277 Opened 9 years ago Closed 9 years ago

Failed to build with --disable-methodjit

Categories

(Core :: JavaScript Engine, defect)

x86_64
Windows CE
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: adrake, Assigned: adrake)

References

Details

(Whiteboard: [fixed-in-tracemonkey])

Attachments

(1 file, 2 obsolete files)

/home/adrake/src/tm/js/src/jsinterpinlines.h: In member function ‘bool js::InvokeSessionGuard::invoke(JSContext*) const’:
/home/adrake/src/tm/js/src/jsinterpinlines.h:589:43: error: ‘struct JSScript’ has no member named ‘getJIT’

Patch forthcoming.
Attached patch Patch v0 (obsolete) — Splinter Review
Adds a ifdef JS_METHODJIT around the condition involving getJIT.
Blocks: 612329
OS: Linux → Windows CE
Attached patch followup patch (obsolete) — Splinter Review
shell/js.cpp needs a similar patch, so here is a unified one. David, would you be willing to review this, or tell me who would?
Attachment #502317 - Flags: review?(dmandelin)
Attachment #502317 - Flags: review?(dmandelin) → review+
Attachment #501381 - Attachment is obsolete: true
I'm going to use this bug for all build failures with --disable-methodjit, since we have 3 of them right now that I know of and various parts of them have already been fixed.

The patch in this bug is nearly all that's left, although part of another of adrake's patches had a warning fix, and the patch attached to this bug has Windows line endings mixed in, so I'll attach a new one and dupe the other bugs here.
Summary: Failed to build jsapi.cpp with --disable-methodjit → Failed to build with --disable-methodjit
Duplicate of this bug: 623137
Duplicate of this bug: 623139
Darn. No simple way to carry over r=dmandelin?
Attachment #502317 - Attachment is obsolete: true
Attachment #503691 - Flags: review+
Duplicate of this bug: 626189
Authorship got mixed up, but:

http://hg.mozilla.org/tracemonkey/rev/7372dac81910
Whiteboard: [fixed-in-tracemonkey]
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 627721
You need to log in before you can comment on or make changes to this bug.