Last Comment Bug 623450 - Fix 579323-1.html
: Fix 579323-1.html
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 623452 623460 623403 623456
  Show dependency treegraph
 
Reported: 2011-01-05 20:40 PST by Phil Ringnalda (:philor)
Modified: 2011-09-15 16:19 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
reftest log (14.92 KB, text/plain)
2011-01-05 20:40 PST, Phil Ringnalda (:philor)
no flags Details
[checked in] temporarily annotate them (3.65 KB, patch)
2011-01-12 08:16 PST, Phil Ringnalda (:philor)
dbaron: review+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor) 2011-01-05 20:40:15 PST
Created attachment 501573 [details]
reftest log

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1294284735.1294285989.30858.gz#err0

Apparently there's something different, because there's a 1200 pixel difference, but I can't see what it is. Failing every time (see http://tbpl.mozilla.org/?noignore=1 on the WinXP opt line), and this blocks getting rid of the totally incapable Win2K3 test slaves that time out constantly, so any help fixing it would be wonderful.
Comment 1 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-01-06 08:34:13 PST
The border is #808080 in the reference vs. #7f7f7f in the test.
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-01-06 08:36:58 PST
(That info courtesy the patch in bug 612505.)
Comment 3 Phil Ringnalda (:philor) 2011-01-08 13:03:28 PST
Hmm, so this and bug 623452 and bug 623456 are all one thing, and that thing is that on whatever code path these WinXP slaves hit, opacity gives a different color depending on whether you set it before the first time it's drawn, or cause it to be redrawn? The other two set opacity on something already drawn, this one resizes a box with an opacity: 0.5 border.
Comment 4 Timothy Nikkel (:tnikkel) 2011-01-08 13:25:49 PST
So when we set the opacity dynamically the element gets its own layer until a timer fires. So the difference is in compositing that layer vs drawing it all in one layer.
Comment 5 Timothy Nikkel (:tnikkel) 2011-01-08 13:34:05 PST
Oh, and canvases always get their own layer, so I think that would explain this one.
Comment 6 Phil Ringnalda (:philor) 2011-01-08 15:06:31 PST
And probably bug 623454 as well, where the video winds up being #010001 instead of #000000. Don't think I've ever filed three dupes of a single bug that I also filed before.
Comment 7 Phil Ringnalda (:philor) 2011-01-08 15:07:20 PST
Err, bug 623460 is the video one.
Comment 8 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-01-09 19:21:42 PST
this test is marked random-if(layersGPUAccelerated) ... that should be true on Windows XP!
Comment 9 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-01-09 19:31:56 PST
That's set based on gWindowUtils.layerManagerType:
http://hg.mozilla.org/mozilla-central/file/4a3866321a14/layout/tools/reftest/reftest.js#l410
which in turn calls GetBackendName:
http://hg.mozilla.org/mozilla-central/file/4a3866321a14/dom/base/nsDOMWindowUtils.cpp#l1512
which looks like it should be accurate.

(Shouldn't whether it's true on Windows XP depend on the video drivers?)
Comment 10 Phil Ringnalda (:philor) 2011-01-09 21:01:56 PST
And just to save someone else the trouble of looking, the other three are also random-if(layersGPUAccelerated), though there are four more which also are, which aren't failing on XP.
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-01-09 21:47:06 PST
(In reply to comment #9)
> That's set based on gWindowUtils.layerManagerType:
> http://hg.mozilla.org/mozilla-central/file/4a3866321a14/layout/tools/reftest/reftest.js#l410
> which in turn calls GetBackendName:
> http://hg.mozilla.org/mozilla-central/file/4a3866321a14/dom/base/nsDOMWindowUtils.cpp#l1512
> which looks like it should be accurate.
> 
> (Shouldn't whether it's true on Windows XP depend on the video drivers?)

Yes. But our Tinderbox test machines should be using a supported driver. I've assumed that was so...
Comment 12 Phil Ringnalda (:philor) 2011-01-10 08:57:45 PST
Is there anything that any of the logs would have that would tell us more about the actual state?

The Win2K3 logs say the same thing in the json sandbox spew at the start, "layersGPUAccelerated":false, but they pass all the random-if tests, which certainly makes it look like it was false for them, is set to false for XP but that is an error and it isn't actually, and that just anyAccel vs none isn't a sharp enough razor to divide passing from random.
Comment 13 Phil Ringnalda (:philor) 2011-01-10 12:02:14 PST
For added fun, bug 623403 comment 2 says that the svg gradient failures are actually random-if(theAccelerationOnXpAndVistaButNot7).
Comment 14 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-01-10 18:56:45 PST
Do we really want to block Firefox 4 on these test failures being fixed? why?
Comment 15 Phil Ringnalda (:philor) 2011-01-10 19:25:01 PST
Because at the time, I didn't realize that the problem was that we knew that we would get crap results on tests like these when we were using hardware acceleration, but we didn't know that we were using it on these slaves, so I thought maybe the failures meant that... dunno, we drew like crap on Win XP, which we hadn't ever tested before.
Comment 16 Phil Ringnalda (:philor) 2011-01-12 08:16:17 PST
Created attachment 503164 [details] [diff] [review]
[checked in] temporarily annotate them

This feels a little like cheating, but it will free up I don't know how many build slaves to go back to building on Windows, instead of running 12 test jobs every push, 11 of which are currently hidden.
Comment 17 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-01-12 08:44:40 PST
Comment on attachment 503164 [details] [diff] [review]
[checked in] temporarily annotate them

r=dbaron
Comment 18 Phil Ringnalda (:philor) 2011-01-12 13:29:25 PST
Comment on attachment 503164 [details] [diff] [review]
[checked in] temporarily annotate them

http://hg.mozilla.org/mozilla-central/rev/2147912ec8e1
Comment 19 Phil Ringnalda (:philor) 2011-01-12 13:30:21 PST
And with that, we're green and visible and no longer blocking turning off the Win2K3 tests.
Comment 20 Treeherder Robot 2011-01-20 15:36:16 PST
dtownsend%oxymoronical.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295565017.1295565743.20086.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test reftest on 2011/01/20 15:10:17

s: talos-r3-leopard-025
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/bugs/579323-1.html | image comparison (==)
Comment 21 Treeherder Robot 2011-01-20 16:08:52 PST
dveditz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295565950.1295567405.28805.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central debug test reftest on 2011/01/20 15:25:50

s: talos-r3-leopard-041
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/bugs/579323-1.html | image comparison (==)
Comment 22 Treeherder Robot 2011-01-20 16:09:16 PST
dveditz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295566744.1295567358.28619.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test reftest on 2011/01/20 15:39:04

s: talos-r3-leopard-048
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/reftests/bugs/579323-1.html | image comparison (==)
Comment 23 Daniel Holbert [:dholbert] 2011-01-20 16:25:18 PST
Comment 20 through comment 22 are not this bug -- they're a different (new) MacOS-specific issue, for which I've filed Bug 627560.  (This bug is WinXP specific)

Adding a few notes to bug summary, so this stops being the target of mis-starring.
Comment 24 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-10 04:20:58 PDT
This test just needs to be fixed, especially now that 649924 has made it not actually test canvas layers.
Comment 25 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-10 19:02:34 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/ed03d172ff06
Tweaked the test and reenabled it everywhere.
Comment 26 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-07-10 19:02:55 PDT
Oops, hasn't landed on central yet.
Comment 27 :Ehsan Akhgari 2011-09-15 16:19:55 PDT
For some reason, this was never marked as FIXED.

Note You need to log in before you can comment on or make changes to this bug.