Closed Bug 627560 Opened 10 years ago Closed 3 years ago

[OS X 10.5] Permaorange in layout/reftests/bugs/579323-1.html

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: dholbert, Assigned: jrmuizel)

References

Details

(Keywords: intermittent-failure, Whiteboard: [test marked as fails-on-10.5])

jrmuizel's push http://hg.mozilla.org/mozilla-central/rev/ac1ca66248e8 (which finished off disabling acceleration on OS X 10.5) seems to have caused permaorange in the reftest 579323-1.html on "OS X opt" & "OS X debug"

The text is just a rectangular border, and the failure is only 4px of difference (each corner of the box being a mismatch)

The corner pixel is #808080 in the reference vs. #7f7f7f in the test.

See also Bug 623450 for a similar issue (but for the whole border) on WinXP.
OS: Linux → Mac OS X
Hardware: x86_64 → x86
Blocks: 583499
mattwoodrow points out that this test actually has probably been failing for a while (though maybe in a different way) -- it's just that it's annotated as "random-if(layersGPUAccelerated)" which has been true on 10.5 until jrmuizel's push in comment 0).

mattwoodrow verified that the cycle before jrmuizel's push was TEST-KNOWN-FAIL(EXPECTED RANDOM) for that test.
I disabled the test <http://hg.mozilla.org/mozilla-central/rev/de4b7372ff3a>, pending further investigation.  Assigning to Jeff.
Assignee: nobody → jmuizelaar
Whiteboard: [orange] → [orange][test disabled]
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296069188.1296070550.10435.gz
OS X 10.5 comm-central-trunk debug test reftest on 2011/01/26 11:13:08
{
REFTEST TEST-UNEXPECTED-PASS | file:///builds/slave/test/build/reftest/tests/layout/reftests/bugs/579323-1.html | image comparison (==)
}
Whiteboard: [orange][test disabled] → [orange][test (not fully) disabled]
(In reply to comment #7)
> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296069188.1296070550.10435.gz
> OS X 10.5 comm-central-trunk debug test reftest on 2011/01/26 11:13:08
> {
> REFTEST TEST-UNEXPECTED-PASS |
> file:///builds/slave/test/build/reftest/tests/layout/reftests/bugs/579323-1.html
> | image comparison (==)
> }

Any idea why this is still happening on SeaMonkey 10.5?


(In reply to comment #8)
> surkov.alexander%gmail.com
> Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test reftest on
> 2011/01/26 19:09:46

That is bug 629196.
(In reply to comment #9)
> (In reply to comment #7)
> > REFTEST TEST-UNEXPECTED-PASS |
> 
> Any idea why this is still happening on SeaMonkey 10.5?

Oh, it actually passes!
I wonder what the FFvsSM difference is: OS (minor) version, some build config, ...?
Yeah, technically "disabled" in comment 5 was incorrect -- ehsan marked the test as *failing* on 10.5.  That seemed to be the right annotation, up until comment 7 - no idea what happened there...

From looking at the screenshot from the reftest failure log, all of the corners of the box are #808080 (whereas when it fails, the testcase has the corners at #7f7f7f).
Whiteboard: [orange][test (not fully) disabled] → [orange][test marked as fails-on-10.5]
> From looking at the screenshot from the reftest failure log
(er, s/failure log/unexpected pass log/ :))
Whiteboard: [orange][test marked as fails-on-10.5] → [test marked as fails-on-10.5]
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.