Closed Bug 623462 Opened 10 years ago Closed 8 years ago

add environment variable to make breakpad write a fuller minidump, and not submit

Categories

(Toolkit :: Crash Reporting, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
firefox21 --- fixed
firefox22 --- fixed

People

(Reporter: shaver, Assigned: benjamin)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

I've been trying to figure out how to make it easier for people, especially testers, to capture precious, precious full minidumps to aid in debugging.  I wrote a wiki page describing it, but what if -- what if! -- we already had a minidump writer thingy in our app?

So I think we should add support for MOZ_FULL_MINIDUMP_FILE that generates a fuller minidump and saves it off to the filename specified in the environment variable.  That would make it very easy for the willing to become the able.

I don't know what to do on Mac or Linux, but it's possible that it could be done with some hairier code.
Related: bug 620974. It'd be fairly easy to support this on Windows, we'd just change the value of the parameter we're passing into the constructor in that patch based on the environment variable, and also disable crash report submission.

Mac/Linux would require new code to be written, since they only know how to write *mini*dumps. The value proposition there is also not as great, since we don't have native debuggers that can handle minidumps like we do on Windows.
Depends on: 620974
Yeah, I might even take a whack at it, it's so easy!
Duplicate of this bug: 639559
Attached patch Env var, full dump, rev. 1 (obsolete) — Splinter Review
Ted, I'd kinda like to take this for the 19.0.1 respin.
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #718483 - Flags: review?(ted)
Comment on attachment 718483 [details] [diff] [review]
Env var, full dump, rev. 1

Review of attachment 718483 [details] [diff] [review]:
-----------------------------------------------------------------

As written I don't think we can take this. This will write a full dump but still try to submit it to crash-stats, which is doomed to fail. If we enable this behavior we should also not submit the dump.
Attachment #718483 - Flags: review?(ted) → review-
Ted, I'm really just looking to use this myself, and I know enough not to submit it (I'd be using it with MOZ_CRASHREPORTER_NO_REPORT anyway).
Attachment #718483 - Flags: review- → review?(ted)
Attachment #718522 - Flags: review?(ted)
Comment on attachment 718522 [details] [diff] [review]
Env var, full dump, rev. 2

Review of attachment 718522 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, this is better.
Attachment #718522 - Flags: review?(ted) → review+
Comment on attachment 718522 [details] [diff] [review]
Env var, full dump, rev. 2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Feature
User impact if declined: Less able to debug intermittent Radeon graphics driver issues
Testing completed (on m-c, etc.): None
Risk to taking this patch (and alternatives if risky): Very low risk, should be debugging code activated by an environment variable only
String or UUID changes made by this patch: None,
Attachment #718522 - Flags: approval-mozilla-release?
Attachment #718522 - Flags: approval-mozilla-beta?
Attachment #718522 - Flags: approval-mozilla-aurora?
Attachment #718483 - Attachment is obsolete: true
Attachment #718483 - Flags: review?(ted)
Once this lands will there be anything QA can do to confirm it's working as expected?
Not effectively, no.
https://hg.mozilla.org/mozilla-central/rev/55d8934477f6
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 718522 [details] [diff] [review]
Env var, full dump, rev. 2

Approving for tip of all branches. Thanks for the quick fix all!
Attachment #718522 - Flags: approval-mozilla-release?
Attachment #718522 - Flags: approval-mozilla-release+
Attachment #718522 - Flags: approval-mozilla-beta?
Attachment #718522 - Flags: approval-mozilla-beta+
Attachment #718522 - Flags: approval-mozilla-aurora?
Attachment #718522 - Flags: approval-mozilla-aurora+
Target Milestone: --- → mozilla22
Marking this bug [qa-] based on comment 12. Please add qawanted keyword if there's something QA can do here to help.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.