Closed Bug 623493 Opened 11 years ago Closed 10 years ago

[OGL] Fennec crash [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d034 ][@ libGLESv2_POWERVR_SGX540_120.so@0xe3b4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d048 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1cfe8 ]

Categories

(Core :: Graphics, defect)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 696768
Tracking Status
fennec + ---

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, topcrash)

Crash Data

It is a new crash signature. Crashes first appeared in 4.0b4pre/20110104.
It is #8 top crasher in Fennec 4.0b4pre for the last week.

Signature	libGLESv2_POWERVR_SGX540_120.so@0x1cfd4
UUID	d581ec9c-d580-4926-accc-3a0d32110105
Time 	2011-01-05 22:59:06.802322
Uptime	9
Last Crash	15 seconds before submission
Install Age	37378 seconds (10.4 hours) since version was first installed.
Product	Fennec
Version	4.0b4pre
Build ID	20110105042401
Branch	2.0
OS	Linux
OS Version	0.0.0 Linux 2.6.32.9 #1 Wed Nov 10 14:57:37 KST 2010 armv7l
CPU	arm
Crash Reason	SIGSEGV
Crash Address	0x6bc000
App Notes 	samsung GT-P1000
samsung/GT-P1000/GT-P1000/GT-P1000:2.2/FROYO/XXJK5:user/release-keys

Frame 	Module 	Signature [Expand] 	Source
0 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 	
1 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0x1cfa3 	
2 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0x2001f 	
3 	libGLESv2_POWERVR_SGX540_120.so 	libGLESv2_POWERVR_SGX540_120.so@0x20f23 	
4 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:76
5 	libxul.so 	mozilla::gl::GLContext::UploadSurfaceToTexture 	nsAutoPtr.h:968
6 	libxul.so 	mozilla::gl::TextureImageEGL::DirectUpdate 	gfx/thebes/GLContextProviderEGL.cpp:1154
7 	libxul.so 	mozilla::layers::ShadowBufferOGL::Upload 	gfx/layers/opengl/ThebesLayerOGL.cpp:653
8 	libxul.so 	mozilla::layers::ShadowThebesLayerOGL::Swap 	nsAutoPtr.h:968
9 	libxul.so 	mozilla::layers::ShadowLayersParent::RecvUpdate 	PLayers.h:532
10 	libxul.so 	mozilla::layers::PLayersParent::OnMessageReceived 	PLayersParent.cpp:222
11 	libxul.so 	mozilla::dom::PContentParent::OnMessageReceived 	PContentParent.cpp:1218
12 	libxul.so 	mozilla::ipc::SyncChannel::OnDispatchMessage 	ipc/glue/SyncChannel.cpp:172
13 	libxul.so 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne 	ipc/glue/RPCChannel.cpp:436
14 	libxul.so 	RunnableMethod<mozilla::ipc::RPCChannel, bool , Tuple0>::Run 	ipc/chromium/src/base/task.h:308
15 	libxul.so 	mozilla::ipc::RPCChannel::DequeueTask::Run 	RPCChannel.h:475
16 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:344
17 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:354
18 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:451
19 	libxul.so 	mozilla::ipc::DoWorkRunnable::Run 	ipc/glue/MessagePump.cpp:71
20 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
21 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
22 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
23 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:220
24 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:512
25 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:198
26 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:192
27 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3697
28 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:131
29 	libc.so 	libc.so@0x111b3 	
30 	libc.so 	libc.so@0x10ca3 

According to the low ADU, the regression range "could" be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d641b5c7774e&tochange=7f2b60765d01	

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=libGLESv2_POWERVR_SGX540_120.so%400x1cfd4
tracking-fennec: --- → ?
It is a more generic and older issue so the regression range in comment 0 is wrong.

http://crash-stats.mozilla.com/query/query?product=Fennec&range_value=4&range_unit=weeks&query_search=signature&query_type=startswith&query=libGLESv2_POWERVR_SGX540_120.so&build_id=&process_type=any&hang_type=any&do_query=1
Summary: Fennec crash [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ] → Fennec crash [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d034 ][@ libGLESv2_POWERVR_SGX540_120.so@0xe3b4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d048 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1cfe8 ]
blocking2.0: --- → ?
tracking-fennec: ? → 2.0+
Summary: Fennec crash [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d034 ][@ libGLESv2_POWERVR_SGX540_120.so@0xe3b4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d048 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1cfe8 ] → [OGL] Fennec crash [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d034 ][@ libGLESv2_POWERVR_SGX540_120.so@0xe3b4 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1d048 ][@ libGLESv2_POWERVR_SGX540_120.so@0x1cfe8 ]
The DirectUpdate code may have caused this.
blocking2.0: ? → ---
I believe this was fixed by a patch cjones landed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Crash in Fennec 4.0b4pre/20110112: bp-8f1642af-5e66-4678-9821-a0c122110112.
So it is not fixed.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
tracking-fennec: 2.0+ → 2.0b4+
tracking-fennec: 2.0b4+ → 2.0next+
tracking-fennec: 2.0next+ → 6+
tracking-fennec: 6+ → 7+
Crash Signature: [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1d034 ] [@ libGLESv2_POWERVR_SGX540_120.so@0xe3b4 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1d048 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfe8 ]
tracking-fennec: 7+ → +
Crash Signature: [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1d034 ] [@ libGLESv2_POWERVR_SGX540_120.so@0xe3b4 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1d048 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfe8 ] → [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfd4 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1d034 ] [@ libGLESv2_POWERVR_SGX540_120.so@0xe3b4 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1d048 ] [@ libGLESv2_POWERVR_SGX540_120.so@0x1cfe8 ]
Ajuma is working on the crashes with addresses 0xe8** under bug 695246. He found that they are related to glTexSubImage2D with a non default framebuffer.
Depends on: 695246
Status: REOPENED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 696768
You need to log in before you can comment on or make changes to this bug.