Auth: cancel button returns auth prompt (not 401 error page)

RESOLVED DUPLICATE of bug 43009

Status

()

Core
Networking: HTTP
P3
normal
RESOLVED DUPLICATE of bug 43009
17 years ago
15 years ago

People

(Reporter: Nasiruddin M.S, Assigned: Darin Fisher)

Tracking

({arch})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: suntrak-n6,, URL)

(Reporter)

Description

17 years ago
Netscape Build : 12/04/2000
Platform : Solaris2.8(sparc)

To reproduce,
(1) Launch the browser
(2) Visit the URL http://www.onlinevarsity.com
(3) Click on the 'Login' icon on left hand side of the page.
(4) A authentication window comes up, asking for the username and password.
    Enter any invalid username and password and press 'ok' button.

Actual result:
--------------
The authentication window comes up again asking the user to enter the
username,password again.

Expected result:
----------------
A window saying 'Authorization failed' should comes up (Should give some
indication that the username and password entered are invalid).This works fine
on netscape 4.75.
(Reporter)

Updated

17 years ago
Whiteboard: suntrak-n6
(Assignee)

Comment 1

17 years ago
Added the arch keyword.  Authentication prompting is being changed, and this
should be addressed in those changes.
Keywords: arch
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 2

17 years ago
Well reproduced under Linux(build 2001040805) and under WinNT(build
2001040604)

Comment 3

17 years ago
Updating Platform and OS categories to All based on comments from Alexei
OS: Solaris → All
Hardware: Sun → All

Comment 4

16 years ago
*** Bug 139389 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
The looping could be just reading the 401 from cache again (lather; rinse;
repeat;), or cancel could be reloading the page on the network.

This bug is old, the desired behavior is described in a previous bug.



*** This bug has been marked as a duplicate of 43009 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
QA Contact: tever → httpqa
Resolution: --- → DUPLICATE
Summary: The Http authentication doesn't display message for invalid username and password. → Auth: cancel button returns auth prompt (not 401 error page)
Whiteboard: suntrak-n6 → suntrak-n6,
You need to log in before you can comment on or make changes to this bug.