Middle-clicking back/forward/reload of an AppTab makes the duplicate tab also an AppTab

VERIFIED FIXED in Firefox 4.0b10

Status

()

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Unfocused, Assigned: dao)

Tracking

Trunk
Firefox 4.0b10
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When middle-clicking on back/forward/reload, while an AppTab is the current tab, the new tab will also be an AppTab. This came as a surprise - I'd expect the new tab to be a normal tab, as every other action opens a normal tab.
(Assignee)

Updated

8 years ago
Assignee: nobody → dao
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
(Assignee)

Comment 1

8 years ago
Created attachment 502919 [details] [diff] [review]
patch
Attachment #502919 - Flags: review?(paul)
(Assignee)

Updated

8 years ago
Attachment #502919 - Flags: approval2.0?
Attachment #502919 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 2

8 years ago
http://hg.mozilla.org/mozilla-central/rev/b63e69b2e831
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
(Assignee)

Updated

8 years ago
Flags: in-testsuite+
Duplicate of this bug: 612231
Verified using Minefield nightly from 2011-01-22.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.