Drag drop on background from expanded stack window causes abnormal behavior

VERIFIED FIXED

Status

defect
P3
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: george.carstoiu, Assigned: mitcho)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][visual][WFM?])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre

Dragging a tab from the expanded stack onto the background in panorama keeps the orientation from the stack and does not separate the dragged tab into a separate/stand-alone group.

Reproducible: Always

Steps to Reproduce:
1.Open several tabs
2.In panorama view minimize the group until the tabs get stacked together 
3.Press Expand button
4.From list of tabs drag and drop one of them on the background
5.Click on the moved tab

Actual Results:  
The thumbnail of the dragged tab keeps the orientation from the stack and when clicked, browser opens tab as being part of the group from which it was taken.

Expected Results:  
A new stand-alone group is formed having the thumbnail with the right orientation.
(Reporter)

Comment 1

8 years ago
Posted image Screenshot
Reproduced on trunk, on Mac.

Not only does it not un-rotate, it doesn't seem to get the non-tabInGroup styling, and creating a group under it doesn't sweep it up and make it a child. Clearly, something odd happens.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P3
Hardware: x86 → All
Whiteboard: [good first bug][visual]
Blocks: 627096
Assignee: nobody → mitcho
Status: NEW → ASSIGNED
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre

Just checked again in yesterday's nightly. I'm unable to reproduce this anymore. It may have gotten fixed already by some other patch.
Keywords: qawanted
Whiteboard: [good first bug][visual] → [good first bug][visual][WFM?]
(Reporter)

Comment 4

8 years ago
Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

Checked it with the latest build and I was unable to reproduce issue also.
Fantastic. Thanks for checking.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified with minefield build of 20110217
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.