Undo Close Tab reopens the tab in a new tab group

RESOLVED DUPLICATE of bug 586198

Status

RESOLVED DUPLICATE of bug 586198
8 years ago
2 years ago

People

(Reporter: moz.teodosia, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Dependency tree / graph

Details

(Whiteboard: [4b9])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre

Undo Close Tab reopens a closed tab in a new group, not in the current group.

Reproducible: Always

Steps to Reproduce:
1.Create a new profile an make sure there is only one group in Group View.
2.Open at least two tabs (in normal view).
3.Close one of the tabs.
4.Right click on the remaining tab and select Undo Close Tab from the context menu.
5.Go to Group View.
Actual Results:  
The tab is reopened in a new group which is now in focus.

Expected Results:  
The tab should reopen in the same group it was closed.

The issue is also reproducible if using History->Recently Closed Tabs.
(Reporter)

Updated

8 years ago
Depends on: 587874, 586198
Version: unspecified → Trunk
Nominating for blocking because it is a regression. The same, earlier bug 586198 had blocked a previous beta.
blocking2.0: --- → ?
Keywords: regression
(Reporter)

Comment 2

8 years ago
The problem started happening with build Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre.
blocking2.0: ? → ---
Dupe of Bug 623867?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586198
(Reporter)

Updated

8 years ago
Whiteboard: [4b9]
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.