Titlebar too big after leaving full screen if tab groups were used [tabs in titlebar]

VERIFIED FIXED in Firefox 4.0b10

Status

()

VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: vykintasv, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 4.0b10
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker][fx4-fixed-bugday])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110107 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110107 Firefox/4.0b9pre

If the window is maximized and Tabs on Top are enabled, leaving full screen results in a too big titlebar if Tab Groups were used.

Reproducible: Always

Steps to Reproduce:
1. Have tabs drawn in titlebar ('Tabs on Top' enabled and window maximized)
2. Hit F11 to enter full screen
3. Hit Ctrl+E to enter Tab Groups
4. Hit Esc to leave Tab Groups
5. Hit F11 to leave full screen
Actual Results:  
The titlebar is way too big.

Expected Results:  
It should be normal.
(Reporter)

Updated

8 years ago
Blocks: 572160
blocking2.0: --- → ?
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Created attachment 502226 [details]
screenshot showing big titlebar

Comment 2

8 years ago
Confirmed!

Comment 3

8 years ago
Confirmed on latest hourly.
http://hg.mozilla.org/mozilla-central/rev/df3c1150dd7a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110107 Firefox/4.0b9pre ID:20110108005407

It happens with Aero,Aero Basic, Classic. and Luna too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Confirmed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110108 Firefox/4.0b9pre

Comment 5

8 years ago
Confirmed on Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110108 Firefox/4.0b9pre.
I can't reproduce this on Windows 7 :/
Keywords: qawanted

Comment 7

8 years ago
I can reproduce this on windows as long as I perform steps 2, 3, and 4 without any intermediary actions. It's easily fixed by leaving restoring the window and re-maximizing though. Needs to be fixed for final but I don't think it should block b9.
(Assignee)

Updated

8 years ago
Assignee: nobody → dao
Status: NEW → ASSIGNED
Component: Theme → General
Keywords: qawanted
QA Contact: theme → general
(Assignee)

Comment 8

8 years ago
Created attachment 502783 [details] [diff] [review]
patch

tested on Win XP and 7
Attachment #502783 - Flags: review?(gavin.sharp)
Why was the bug occurring and why does that fix it?
OS: Windows 7 → Windows XP
I can reproduced it in Windows 7. Hence this also affect Windows 7.
(Assignee)

Comment 11

8 years ago
tabview/ui.js calls TabsInTitlebar.allowedBy("tabview-open", ...), but the calculations in TabsInTitleBar._update fail when the toolbars are moved off-screen. The patch prevents tabs in the titlebar from being toggled while the fullscreen UI is active.
blocking2.0: ? → final+
Whiteboard: [softblocker]
With this patch applied, the title bar seems to be sized incorrectly after transitioning out of fullscreen and into maximized state (or possibly only maximized->fullscreen->maximized).
blocking2.0: final+ → ---
OS: Windows XP → All
blocking2.0: --- → final+
OS: All → Windows XP
(Assignee)

Comment 13

8 years ago
(In reply to comment #12)
> With this patch applied, the title bar seems to be sized incorrectly after
> transitioning out of fullscreen and into maximized state (or possibly only
> maximized->fullscreen->maximized).

I think I saw this problem when I implemented tabs in the titlebar. Not sure why I didn't see it now. Anyway, the problem is that the fullscreen event is dispatched before the actual mode change, so the measurements can be off.
(Assignee)

Comment 14

8 years ago
Created attachment 503440 [details] [diff] [review]
patch v2

Slightly different approach, disables all updates in fullscreen mode.
Attachment #502783 - Attachment is obsolete: true
Attachment #503440 - Flags: review?(gavin.sharp)
Attachment #502783 - Flags: review?(gavin.sharp)

Updated

8 years ago
Flags: in-litmus?(jbecerra)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 626039
Attachment #503440 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 16

8 years ago
http://hg.mozilla.org/mozilla-central/rev/e1a0d3b39846
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
Duplicate of this bug: 628288
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker] → [softblocker][fx4-fixed-bugday]
It's fixed, I can confirm.

Updated

4 years ago
Flags: in-litmus?(jbecerra)
You need to log in before you can comment on or make changes to this bug.