Shift+delete (permanent delete) needs to prompt

VERIFIED WONTFIX

Status

SeaMonkey
MailNews: Message Display
P3
major
VERIFIED WONTFIX
17 years ago
3 years ago

People

(Reporter: Jesse Ruderman, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({dataloss})

Trunk
Future
x86
Windows 98
dataloss

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Shift+delete is usually used for "cut", but in Mozilla MailNews, it permanently 
deletes the message without prompting.  This means that I can accidentally 
delete a message when I'm trying to move it.

This bug doesn't cover other methods of permanently deleting things (delete 
from trash, shift+click on "delete" toolbar button, etc), but maybe it should.
(Reporter)

Updated

17 years ago
Keywords: dataloss
(Reporter)

Comment 1

17 years ago
See also bug 62497, impossible to undo shift+deleting a message.

Updated

17 years ago
QA Contact: esther → sheelar

Comment 2

17 years ago
reassigning to sspitzer. Personally, I don't think there needs to be a prompt. 
Perhaps the very first time you do this as a warning. But the idea behind it is 
for it to be a fast way to delete
Assignee: putterman → sspitzer

Comment 3

17 years ago
Is there a spec for this?  Can we get one before we add a hunk of UI that many
users are not going to want.

Comment 4

17 years ago
Shift delete was force delete [skipping trash] in nc4, i believe that is the 
correct behavior, and i use it for that purpose. perhaps we should kill 
Shift-delete as cut support.

Comment 5

17 years ago
I don't see people hitting Shift+Del by accident.  Think its ok as a direct 
delete (skip trash).  Does "undo" reverse this action?

Comment 6

17 years ago
no. force deletes aren't undoable. the same is true w/ windows explorer.

Comment 7

17 years ago
I think what the reporter is prob referring to is the older win3.1 keyboard
shortcuts for clipbaord transfer. Yes they did not always have acc-x,c and v.
Many apps on win32 systems still support these older shortcuts (although they
are not showing them) alongside with the newer familiar ones.
(Reporter)

Comment 8

17 years ago
cc aaronl

Updated

17 years ago
Target Milestone: --- → Future

Comment 9

17 years ago
Agree that shift+delete sometimes means "cut".

Should it bring up a confirm dialog with a checkbox "Don't show this dialog again"?

BTW, do we have a generic way of easily creating dialogs like that?

Comment 10

17 years ago
Aaron, it's very easy with nsIPromptService.

Comment 11

16 years ago
I made a patch to prompt user if Shift+Delete is pressed. I will post it here 
soon.

Comment 12

16 years ago
Created attachment 99810 [details] [diff] [review]
Patch V1

Show a dialog to prompt user to confirm if they shift+delete the message.
There are two cases here, one in mail 3 pane window and the other in standalone
message window.
Since the focus is on the OK button by default, it is very handy for the user
to press SPACE bar to confirm the deletion.
Outlook and OE have this dialog. I'd like mozilla have this dialog, too. This
can avoid accidently deletion of messages.  I have made this mistake before.

seek r= and sr= for this patch.

Comment 13

16 years ago
this would make shift delete useless. It's meant to be the fastest way to delete
messages, no trash, no confirmation, etc. The only way this should be considered
is if it was controlled by a pref that was turned off by default.

Comment 14

16 years ago
I can make it controlled by a pref that was turned off by default.
Do we want to make it a hidden pref or user can control it through preference 
GUI? 

Comment 15

16 years ago
Created attachment 99945 [details] [diff] [review]
Patch V2 (Added preference control)

This patch added a preference item in Edit-->Preferences-->Mail & Newsgroups's
General Settings.
If we just want a hidden preference, just ingore the changes to 
pref-mailnews.xul, pref-mailnews.dtd.
Please r= this patch. Thanks!
Attachment #99810 - Attachment is obsolete: true
>no. force deletes aren't undoable. the same is true w/ windows explorer.

I just tried it (on an imap server), and undo works. so why do we need this patch?

Comment 17

16 years ago
that's a good point. Unfortunately, it doesn't work for local folders (there's a
bug filed on that). I think it would be better just to fix undo for local
folders than to put this patch in.

Comment 18

15 years ago
As I checked, the "Can't undo shift delete of local messages" bug id is 132121.
If undo for "Shift+Delete" for all messages works, I agree with the above comments.

bienvenu, so can I mark this bug as WONTFIX?

Comment 19

15 years ago
yes, thx, I'll just mark it wontfix while I'm here.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
QA Contact: sheelar → stephend
verified, I think (and hope) that a consensus has been reached.
Status: RESOLVED → VERIFIED

Comment 21

13 years ago
*** Bug 225713 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 22

3 years ago
There's a prompt since 2013. So, someone dupes this bug to bug 308690?
You need to log in before you can comment on or make changes to this bug.