{compat} Undefined rendering for blocks larger than viewport

VERIFIED FIXED in M17

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: e9026662, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

(Reporter)

Description

19 years ago
open the url 'www.arstechnica.com' and scroll to the right
you will see that the background does not display correctly in the
rightmost area of the page (where it says 'Reviews:', 'Articles', etc.)

Updated

19 years ago
Assignee: rickg → kipp

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: background does not display correctly → {compat} background does not display correctly

Comment 1

19 years ago
The issue is a problem with CSS compatability with the rest of the world in
handling blocks whose children are larger than the block.
Severity: normal → major
Priority: P3 → P2
Summary: {compat} background does not display correctly → undefined background with narrow window
Whiteboard: (py8ieh:will make minimal test page)
Actually, there is a more serious problem here. Shrink the viewport so that the
right hand sidebar is not visible. Move the horizontal scroll bar all the way
to the right so that the left hand side scroll bar is no longer visible.

Now widen and reshrink the window. There are some very dodgy things going on
here, particularly with undefined backgrounds.

There is a copy of this page here:
   http://www.bath.ac.uk/%7Epy8ieh/internet/projects/mozilla/arstechnica.html

I intend to boil that page down to a minimal test case.
I have replaced the copy of the original page which is given above with a
minimal test case showing the problem:

   http://www.bath.ac.uk/%7Epy8ieh/internet/projects/mozilla/arstechnica.html

The problem is that blocks that are wider than the viewport do not redraw
correctly when the viewport is resized. The above test page is self
explanatory, and gives the steps required to reproduce the bug.
Severity: major → normal
Priority: P2 → P3
Summary: undefined background with narrow window → Undefined rendering for blocks larger than viewport
Whiteboard: (py8ieh:will make minimal test page)
Target Milestone: M15
Blocks: 3061

Comment 4

19 years ago
The above (www.bath.ac.uk) testcase works for me under M7/Linux. The
www.arstechnica.com site still exhibits the non-displaying background
if you scroll to the right, though.
To see the problem on the small (www.bath.ac.uk) test case, you have to
first open the page, then scroll right, *and then resize your window*.

I'll look into making the small test case better.
Whiteboard: [TESTCASE]
I've improved the test case. The (same) bug is now much more clearly visible.
chadh@pobox.com: Thanks for prompting me.

Updated

19 years ago
Severity: normal → major
Priority: P3 → P5
Summary: Undefined rendering for blocks larger than viewport → {compat} Undefined rendering for blocks larger than viewport
This problem doesn't occurs on M8 release.
Already fixed?

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
I can't reproduce the problem anymore, so I'm closing the bug. Please reopen or
make a new more specific bug if there actually is something there. The testcase
and the original url render flawlessly now :-)

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
I'm not seeing this problem either with the Sept 23rd build.
You need to log in before you can comment on or make changes to this bug.