Closed Bug 3061 Opened 21 years ago Closed 18 years ago

ea.com - Various problems at www.ea.com

Categories

(Tech Evangelism Graveyard :: English US, defect, P4)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nbaca, Assigned: arun)

References

()

Details

(Keywords: compat, top100)

Viewer.exe from 2/5/99.
NT4, MAC 8.5, Linux.
website: www.ea.com
qa assign to chrisd@netscape.com

Problem: NT. To the right of the banner "Welcome to Electronic Arts" which is on
a black background, to the right it becomes a white background. It should be
black until it meets the blue column to the right.
4.5.1: NT shows same problem. Mac draws it correctly which is black.
Other 5.0: Mac draws it correctly which is black. Linux only shows two broken
images at the top.
*** Bug 3067 has been marked as a duplicate of this bug. ***
Assignee: rickg → kipp
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
QA Contact: 3853 → 4144
Target Milestone: M4
Filling in QA Assigned for a check with latest Apprunner build.  Update
component if still occurs please.
Unable to verify. Attempting to open the URL in the March 10th Build, causes a
crash.
Priority: P2 → P3
I can't reproduce this bug. The page does have other problems, in particular
many of the images don't load.
Whiteboard: (py8ieh:need to update summary)
Target Milestone: M15
I will examine this bug to make sure it is still occuring and if it is, I will
update the summary.

[dbaron: removing M15 marker to get this back on our radar]
Assignee: kipp → py8ieh=bugzilla
Status: ASSIGNED → NEW
Whiteboard: (py8ieh:need to update summary) → (py8ieh:will examine)
Status: NEW → ASSIGNED
[Assigning bug to myself. I'll examine it and then reassign it to Kipp once
I have narrowed the problem down. It appears, though, that there _are_ no
new bugs here.]
Whiteboard: (py8ieh:will examine) → (py8ieh:will examine further)
Ok, I finally got around to investigating this.

The original problem does not occur on W98. Could the reporter please see if
it still occurs on their platform? Thanks.

There are four other problems visible on this page:

 1. The background of the "Go" button for the "Quick Search" edit box is
    undefined. I will investigate further.
 2. There are some <FONT> parsing problems. See bug 991.
 3. The tables are ignoring their parent's alignment. See bug 6150.
 4. The (javascript, I believe) twirling baton thing leaves trails.
    I will investigate this further too.
Build 1999061409 on Win32/NT4.

I was able to reproduce using NT4 and Win95.
(Having problems with Linux and Mac so unable to try on these platforms for now)

Steps to Reproduce:
1. Open Apprunner
2. Go to www.ea.com
3. Notice the horizontal scroll bar below the page.
4. Move the horizontal scroll bar to the right. Now you should see that there is
a white border that starts at the top right corner and continues down the right
side of the entire page.

Note: If the window is resized larger so that the horizontal bar disappears then
the white border no longer appears and it looks correct.
Reproduces with Mac and Win 95 Builds (1999061409).
1) Launch Apprunner
2) After default page opens, resize the browser window so that you have a
horizontal scroll bar.
3) Go to www.ea.com
4) After this loads, move the horizontal scroll bar all the way to the right.
5) After this is done, look at the right edge of page. There is a white border
that starts from the top banner image and moves to the bottom of page.
Summary: [PP]Top border becomes white 3/4s to the right → Various problems at www.ea.com
Thanks. That problem is a dup of bug 6245.

I am changing the summary to something more generic. I will narrow the
two remaining bugs mentioned above down to simple test cases.
Whiteboard: (py8ieh:will examine further) → (py8ieh:will examine still further)
The twirling baton thing is now covered by bug 8409.
Whiteboard: (py8ieh:will examine still further)
The undefined background problem is now covered by bug 8489.
Depends on: 991, 6150, 6245, 8409, 8489
Once all five bugs mentioned above have been fixed, I will revisit this bug
to make sure that http://www.ea.com/ renders correctly, as compared to
legacy browsers.
Depends on: 7112
No longer depends on: 6150
Correcting dependancy on bug 6150. Bug 6150 is a dup of bug 7112, so changing
dependancy to bug 7112.
Blocks: 4574
*** Bug 4574 has been marked as a duplicate of this bug. ***
Once all fives bug are fixed, I will verify that bug 4574 is also fixed.
Ian - all 5 listed dependencies are fixed.  I guess this needs looking at.

Correcting component.
Component: Viewer App → Layout
Depends on: 28193
Moving off to M16. There are two additional problems visible now:
   bug 28193, window.open() ignores 'scrollbars=no' parameter
   bug 24036, Residual style solution not fully backwards compatible  
Depends on: 24036
Keywords: 4xp
Target Milestone: M16
bug 24036 has no milestone. bug 28193 was moved to M21 today. since this bug
can't be resolved until they are cleared, either they need to be set for M16 or
this bug (and bug 24036) need to be moved to M21.
M16 has been out for a while now, these bugs target milestones need to be 
updated.
Priority: P3 → P5
Hardware: PC → All
Target Milestone: M16 → M19
OS: Windows NT → All
Priority: P5 → P4
All the dependencies for this bug have been resolved (24036 is WONTFIX).  This
needs review and (hopefully) closing.
Great. They've blocked out our browser altogether now.
I'm sending this to Evangelism. We've done our best to work with this site...
Assignee: ian → evangelism
Status: ASSIGNED → NEW
Component: Layout → Evangelism
QA Contact: petersen → zach
This is the text of the message they give when blocking NS6/Mozilla.  Hopefully
they are following through on this.


EA.com is coming soon for Netscape 6!
We're currently working hard to optimize all our fun, free games for this
exciting new browser. They should be ready in the next few weeks, so please
bookmark this page and check back soon. Until then, you can use Netscape 4.7 to
get full access to our EA.com games.

Keywords: compat, top100
anybody know if we have a recent update from them?
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
-> Arun
Assignee: bclary → aruner
Summary: Various problems at www.ea.com → ea.com - Various problems at www.ea.com
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
The latest message at http://www.ea.com/

"We're sorry, but your browser or Macintosh is not compatible with EA.com.

EA.com games work best with PC's and the following browsers:

Internet Explorer 4.0 and higher
Netscape 4.08 and higher (excluding 6.0 and 6.1)

However, GREAT NEWS! Pogo is now part of the EA.com Network. In a moment, your
will be sent to Pogo, where you can play great FREE card, puzzle and casino
games, win instant cash prizes and much more.

You may be required to login or join, before you can access Pogo.com

Thank you,
EA.com Community Team"
Heh, funny thing is, i just started the switch over to Linux the other night 
(trying to atleast) and well, I can't play on pogo.com with a nightly from 
20011202. I have macromedia flash loaded, and java runtime 2 13_1 or whatever 
the number was.  The games load fine, but I cannot interface with the UI and I 
have no idea why.  It looks exactly the same as it does in IE, but the applets 
themselves are unresponsive.  Is this a Mozilla issue too (seperate bug?), or 
an EA issue?
ok they don't block moz anymore, I'm guessing that we should file indivual bugs
for different problems?
leaving up to arun if to close this.  the main site has been redesigned, and
features lots of AOL ads :). easports.com however, has a stupid bug where we get
IE4 code and not DOM code loaded (see bug 121624, fix at hand).
Keywords: evang500
page was redesigned, cant see any of the mentioned problems, all wfm now
marking fixed
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.