Crash when leaving fullscreen while playing OGG video

RESOLVED DUPLICATE of bug 623728

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 623728
7 years ago
7 years ago

People

(Reporter: kinetik, Unassigned)

Tracking

unspecified
x86
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec2.0+)

Details

(Reporter)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #623728 +++

Not sure if this is a dupe of the cloned bug, sorry if it is.

With a desktop Fennec build:
1. Open local WebM video in Fennec
2. Switch to full-screen
3. Hit Escape to exit full-screen

###!!! ASSERTION: You can't dereference a NULL nsRefPtr with operator->().: 'mRawPtr != 0', file ../../dist/include/nsAutoPtr.h, line 1117
#4  <signal handler called>
#5  0x00007f2a51c241ea in mozilla::ipc::Shmem::Shmem (this=0x7fffc501dcc0, 
    aOther=...) at ../../dist/include/mozilla/ipc/Shmem.h:113
#6  0x00007f2a51c2b1ea in mozilla::layers::SurfaceDescriptor::SurfaceDescriptor
    (this=0x7fffc501dcc0, aOther=...)
    at ../../ipc/ipdl/_ipdlheaders/mozilla/layers/PLayers.h:5640
#7  0x00007f2a51c2aa53 in mozilla::layers::ShadowLayersParent::RecvUpdate (
    this=0x7f2a3ef9eab0, cset=..., reply=0x7fffc501de50)
    at /home/kinetik/fennec/mozilla-central/gfx/layers/ipc/ShadowLayersParent.cpp:438
#8  0x00007f2a518edb05 in mozilla::layers::PLayersParent::OnMessageReceived (
    this=0x7f2a3ef9eab0, __msg=..., __reply=@0x7fffc501e178)
    at PLayersParent.cpp:222
(gdb) p aOther
$2 = (mozilla::layers::SurfaceDescriptor::Shmem &) 
    @0x48: <error reading variable>
(gdb) up
#7  0x00007f2a51c2aa53 in mozilla::layers::ShadowLayersParent::RecvUpdate (
    this=0x7f2a3ef9eab0, cset=..., reply=0x7fffc501de50)
    at /home/kinetik/fennec/mozilla-central/gfx/layers/ipc/ShadowLayersParent.cpp:438
438	                                    newBack->GetShmem()));
(gdb) p newBack
$3 = {mRawPtr = 0x0}
I'm not sure either, but this particular crash is very easy to repro on device (haven't hit it on desktop yet :S ).
This is a different bug.
Different symptom of the same underlying problem.

RESO -> SUBSUMED
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623728
You need to log in before you can comment on or make changes to this bug.