Closed Bug 624639 Opened 10 years ago Closed 10 years ago

Arrows in Bookmarks panel shouldn't change direction until mouse release

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 4.0b12

People

(Reporter: illusionmist62442, Assigned: stefanh)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9pre) Gecko/20110110 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9pre) Gecko/20110110 Firefox/4.0b9pre

Right now, upon mousedown, the arrows in bookmarks arrow panel flip upside down instantly. They should remain their direction until the user release their mouse button.

See the screenshot for comparison with Windows.

Reproducible: Always
Depends on: 620132
Attached image screenshot
Note the 'pressed' state.
Version: unspecified → Trunk
No longer depends on: 620132
Confirming. Fwiw, the current behavior is not consistent with the native ones or the ones in the places window.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 597557
OK, so I think when this was added the idea was to overrule the hover:active icon in editBookmarkOverlay.css. However, the ".expander-down:hover:active" selector is of lower specificity than the "#editBookmarkPanel .expander-down" selector.
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #508477 - Flags: review?(dao)
Attachment #508477 - Flags: review?(dao) → review+
Comment on attachment 508477 [details] [diff] [review]
Fix hover:active state

Really safe ui-glitch fix.
Attachment #508477 - Flags: approval2.0?
(In reply to comment #3)
> OK, so I think when this was added the idea was to overrule the hover:active
> icon in editBookmarkOverlay.css.

Actually, probably not since then I guess the same directions would have been used.
Comment on attachment 508477 [details] [diff] [review]
Fix hover:active state

a=beltzner, zero risk
Attachment #508477 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/553f7b1974a3
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
Verified using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12pre) Gecko/20110220 Firefox/4.0b12pre ID:20110220030351.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.