Last Comment Bug 624743 - Resource protocol shouldn't use nsDependentCString to convert an nsACString to an nsCString
: Resource protocol shouldn't use nsDependentCString to convert an nsACString t...
Status: RESOLVED FIXED
[good first bug][mentor=jdm]
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Edgar Flores
:
: Bill McCloskey (:billm)
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 542907 624738
  Show dependency treegraph
 
Reported: 2011-01-11 08:40 PST by neil@parkwaycc.co.uk
Modified: 2011-08-16 03:13 PDT (History)
3 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Changed nsDependentCString call to nsCString (220 bytes, patch)
2011-08-10 20:52 PDT, Edgar Flores
no flags Details | Diff | Splinter Review
Changed nsDependentCString call to nsCString v2 (945 bytes, patch)
2011-08-11 21:43 PDT, Edgar Flores
benjamin: review+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2011-01-11 08:40:48 PST
This looks as if it just needs an explicit nsCString constructor.
Comment 1 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-04-10 11:35:35 PDT
Relevant code is in the URL field.
Comment 2 Edgar Flores 2011-08-10 20:52:56 PDT
Created attachment 552301 [details] [diff] [review]
Changed nsDependentCString call to nsCString
Comment 3 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-08-10 21:24:03 PDT
Edgar, looks like you didn't qref before uploading.
Comment 4 Edgar Flores 2011-08-11 21:43:08 PDT
Created attachment 552593 [details] [diff] [review]
Changed nsDependentCString call to nsCString v2

Sorry about that
Comment 5 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-08-15 08:24:32 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/2c026a7ff730
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-08-16 03:13:19 PDT
http://hg.mozilla.org/mozilla-central/rev/2c026a7ff730

Note You need to log in before you can comment on or make changes to this bug.