Should not be possible to create an nsDependent(C)String from an nsA(C)String

RESOLVED DUPLICATE of bug 611503

Status

()

Core
String
RESOLVED DUPLICATE of bug 611503
7 years ago
6 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Atul Aggarwal)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

7 years ago
There are a few spots throughout the code base that try to use nsDependent(C)String as if it were PromiseFlat(C)String, which it is not. They usually get lucky because the string being promised turned out to be flat, but we should just remove the bogus constructor (after fixing all the callers).
(Reporter)

Updated

7 years ago
Depends on: 624740
(Reporter)

Updated

7 years ago
Depends on: 624742
(Reporter)

Updated

7 years ago
Depends on: 624743
(Assignee)

Comment 1

6 years ago
Created attachment 572291 [details] [diff] [review]
Patch v1

https://tbpl.mozilla.org/?tree=Try&rev=6bf98ab2ac2b
Assignee: nobody → atulagrwl
Status: NEW → ASSIGNED
Attachment #572291 - Flags: review?(benjamin)
(Assignee)

Comment 2

6 years ago
Comment on attachment 572291 [details] [diff] [review]
Patch v1

Build busted in Windows.
Attachment #572291 - Attachment is obsolete: true
Attachment #572291 - Flags: review?(benjamin)
(Reporter)

Comment 3

6 years ago
(In reply to Atul Aggarwal from comment #2)
> (From update of attachment 572291 [details] [diff] [review])
> Build busted in Windows.
I didn't think the external API had the problem anyway.
(Assignee)

Comment 4

6 years ago
Totally true. Verified now and I thought it was due to my change :P. 

Neil, shouldn't we close this issue if this is not relevant any more otherwise another fool like me will waste some time working on it :)
(Reporter)

Comment 5

6 years ago
Looks like I filed this as a duplicate by mistake...
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611503
You need to log in before you can comment on or make changes to this bug.