Closed Bug 624829 Opened 9 years ago Closed 9 years ago

No Default Search Engine set with fresh profile [browser.search.defaultenginename default value issue]

Categories

(SeaMonkey :: Preferences, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 657215

People

(Reporter: InvisibleSmiley, Unassigned)

Details

With a current SM en-US trunk nightly (tested on Windows and Linux):

STR:
1. create a fresh profile
2. go to Preferences/Browser/Internet Search

Expected:
Something is selected, e.g. Google

Actually:
Nothing is selected.

Observations:
1. browser.search.defaultenginename is set to "Google" by default (see about:config). If you change the status of the pref to "user set" (double click, OK), the drop-down in Preferences is set correctly.
2. browser-prefs.js contains: pref("browser.search.defaultenginename", "chrome://communicator-region/locale/region.properties"); / region.properties contains: browser.search.defaultenginename=Google / the same applies to Firefox (firefox.js, region.properties)
3. The code in pref-search.js (Services.search.defaultEngine.name) returns "Google" even in the default case.
Sorry, this bug didn't show up in my search-fu.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 657215
You need to log in before you can comment on or make changes to this bug.