Closed Bug 657215 Opened 9 years ago Closed 9 years ago

No search engine selected in Internet Search preferences on new profile

Categories

(SeaMonkey :: Search, defect)

defect
Not set

Tracking

(blocking-seamonkey2.1 -, seamonkey2.1 wanted)

RESOLVED FIXED
seamonkey2.1final
Tracking Status
blocking-seamonkey2.1 --- -
seamonkey2.1 --- wanted

People

(Reporter: neil, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(1 file)

The Internet search preference panel fails to show any search engine as selected if the search engine preference is still at its default setting. This is because the preference is actually a localised string.

For some reason bug 410613 deleted the wrong lines when removing the "defaultengine" preference, thus incorrectly changing the type of the "defaultenginename" preference.
Attached patch Proposed patchSplinter Review
The real change is the letter w, which tells prefwindow.xml that this is a localised string.

The appendChild call is unnecessary because appendItem already calls it.

The value set is unnecessary because prefwindow.xml already sets it. (In fact this automatic value set is what exposes the bug.)
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #532515 - Flags: review?(iann_bugzilla)
Dupe of bug 624829 (or vice-versa) I guess.
Duplicate of this bug: 624829
blocking-seamonkey2.1: --- → ?
Attachment #532515 - Flags: review?(iann_bugzilla) → review+
Pushed changeset e8332e7c3d7c to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I want this if we end up doing a respin, not respinning for it alone though.
blocking-seamonkey2.1: ? → -
Target Milestone: --- → seamonkey2.2
Keywords: relnote
Attachment #532515 - Flags: approval-seamonkey2.1?
Attachment #532515 - Flags: approval-seamonkey2.1? → approval-seamonkey2.1+
http://hg.mozilla.org/releases/comm-2.0/rev/0ebf0e23bf22
Keywords: relnote
Target Milestone: seamonkey2.2 → seamonkey2.1final
You need to log in before you can comment on or make changes to this bug.