Firefox 4.0 often shows all tab groups' tabs on startup

VERIFIED FIXED in Firefox 4.0b11

Status

defect
P2
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: nonoitall+mozilla, Assigned: ttaubert)

Tracking

Trunk
Firefox 4.0b11

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

When I use multiple tab groups (which is pretty much constantly) and I open Firefox (restoring the previous session's tabs), Firefox typically shows *all* of my tabs as though there are no separate tab groups at all.  If I click the panorama button and then go back to the group I was in, then it behaves correctly, only showing me tabs from that group.

Reproducible: Sometimes

Steps to Reproduce:
1.  Have multiple tab groups and close Firefox, saving tabs.
2.  Start Firefox.
Actual Results:  
Tabs from all tab groups are shown in the tab bar.

Expected Results:  
Only tabs from the last open tab group should be shown in the tab bar.

This seems to happen almost every time I start Firefox in Windows XP.  It happens rarely (if ever??) when launching Firefox on Linux, even though I'm using a shared profile for both platforms.  It seems like if I start FF in Linux, and the last time I closed it was in Windows, all tabs may show up, however subsequent startups in Linux will work correctly.  Also if I close FF in Linux and then start it in XP, it seems like it always behaves correctly the first time, though subsequent startups in XP will behave incorrectly again, so this may have something to do with how tabs are saved in Windows (XP).
Version: unspecified → Trunk

Comment 1

8 years ago
While unfortunate, this is not that surprising to me. Panorama is entirely unaware of Sync, and we've never tested it in that regard, let alone across different operating systems. :/
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Future
(In reply to comment #1)
> While unfortunate, this is not that surprising to me. Panorama is entirely
> unaware of Sync, and we've never tested it in that regard, let alone across
> different operating systems. :/

Sounds pretty bad. Sync is a built-in feature now.
Target Milestone: Future → ---
(Reporter)

Comment 3

8 years ago
Actually I wasn't using Sync - this is on a dual-boot machine where Linux and Windows XP both have access to the same Firefox profile directory.  Even before I started sharing the profile between OS's though (back when I used it only on XP), the problem still presented almost every time that I started Firefox.  Also, this problem does *not* seem to occur on my laptop w/Windows Vista (64-bit).  (Or at least, it happens rarely enough there that I don't recall it happening.)

So it looks to me like this is something specific not only to the Windows version, but specifically to how it behaves on XP (and possibly 2000, since it's similar to XP, though I've not tested it on 2000).
(Reporter)

Comment 4

8 years ago
With a bit more testing, it seems like this happens more often (exclusively?) when the new Firefox menu is turned on.  I tried switching back to the old-fashioned menus yesterday and FF showed the correct tabs on startup every time.  Today, I switched back to using the Firefox menu and the problem has returned.
I think I've seen the same thing on shutdown. My hunch is that, on startup and shutdown, we may "unhide" all tabs at one point or another, and accidentally flash the full tabbar with all tabs.
(In reply to comment #5)
> I think I've seen the same thing on shutdown. My hunch is that, on startup and
> shutdown, we may "unhide" all tabs at one point or another, and accidentally
> flash the full tabbar with all tabs.

This code, in UI.init, sure looks like the culprit:

      iQ(window).bind("beforeunload", function() {
        Array.forEach(gBrowser.tabs, function(tab) {
          gBrowser.showTab(tab);
        });
      });

Strange that it only happens sometimes or for some people. At any rate, this is leftover from a long time ago and should just get cleaned out!
Blocks: 585689
Posted patch patch v1 (obsolete) — Splinter Review
Removed the lines as Ian suggested. Pushed to try.
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
Attachment #505326 - Flags: review?(ian)
(Assignee)

Updated

8 years ago
OS: Windows XP → All
Hardware: x86 → All
Passed try!
Blocks: 627096
No longer blocks: 585689
Comment on attachment 505326 [details] [diff] [review]
patch v1

Looks good. 

Were you able to repro? When you tried it after removing the lines, did you see any weirdness?
Attachment #505326 - Flags: review?(ian) → review+
No, unfortunately I could not reproduce this. I can't see any weird behaviour though we should probably have an eye on this.
(Assignee)

Updated

8 years ago
Attachment #505326 - Flags: approval2.0?
Attachment #505326 - Flags: approval2.0? → approval2.0+
Attachment #505326 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Comment 12

8 years ago
http://hg.mozilla.org/mozilla-central/rev/1c89c6d9574c
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b10
Target Milestone: Firefox 4.0b10 → ---
Target Milestone: --- → Firefox 4.0b11
I'm still seeing weirdness. Some of my tabs get shoved into the current group, but not all. And to be clear it's not that they're there at startup. Initially I see the right set of tabs, but as soon as I enter tabview the wrong ones are in the current group.

So this might not be the same bug but it's definitely a bug.
So Kevin linked me to bug 628188, which seems to be what is continuing to cause this issue for me. I guess we can keep this FIXED.
verified with nightly build of minefield.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.