WebGL now Glitchy with ANGLE - worked better on beta 8

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: jonrandy, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Googles body browser now does not render properly. Aquarium demo here: https://webglsamples.googlecode.com/hg/aquarium/aquarium.html no longer runs at all

Reproducible: Always

Steps to Reproduce:
1. Load either of the URLS mentioned
2. 
3.
Actual Results:  
Body browser not rendering correctly
Aquarium demo not working at all

Expected Results:  
Both working correctly as in beta 8
(Reporter)

Comment 1

7 years ago
Created attachment 503111 [details]
Incorrect rendering on Body Browser
(Reporter)

Comment 2

7 years ago
I was using a downloaded osmesa32.dll before - is this still being used? About:support reports:

WebGL RendererTransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 10 2011 19:54:16)
Please post the complete Graphics Info.
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> Please post the complete Graphics Info.

Graphics
      
Adapter Description: Mobile Intel(R) 965 Express Chipset Family
Vendor ID: 8086
Device ID: 2a02
Adapter RAM: Unknown
Adapter Drivers: igxprd32
Driver Version: 6.14.10.5218
Driver Date: 1-13-2010
Direct2D Enabled: Blocked on your graphics card because of unresolved driver issues.
DirectWrite Enabled: true
WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 10 2011 19:54:16)GPU Accelerated Windows0/3
(Reporter)

Comment 5

7 years ago
Aquarium demo is ok - it seems they had a JS problem on the site which is now fixed. Most WebGL stuff online now seems to work better. It is just the Body Browser from Google that seems glitchy
Your OSMesa is not being used anymore, you're now getting hardware acceleration directly from your intel driver. You probably want to update that if possible as it's a year old.

It's also possible the real problem is in some ANGLE bug, CC'ing bjacob.
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> Your OSMesa is not being used anymore, you're now getting hardware acceleration
> directly from your intel driver. You probably want to update that if possible
> as it's a year old.
> 
> It's also possible the real problem is in some ANGLE bug, CC'ing bjacob.

OK. Just checked Intel site - the driver I have is latest version.

Also noticed sometimes when I refresh a WebGL, it is incredibly slow (software rendering?), then if I refresh again it is back to full speed. This is the case with any WebGL content
Hrm, so it seems :(. I didn't know Intel wasn't updating drivers on windows XP, that's a real shame.

Comment 9

7 years ago
I can reproduce on
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre ID:20110113030355

  Graphics
        Adapter Description: ATI Radeon HD 4300/4500 Series
        Vendor ID: 1002
        Device ID: 954f
        Adapter RAM: 512

        Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
        Driver Version: 8.801.0.0
        Driver Date: 
        Direct2D Enabled: true
        DirectWrite Enabled: true
        WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 13 2011 03:37:36)
        GPU Accelerated Windows: 1/1 Direct3D 10
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

7 years ago
In adittion to comment#9,
The problem does not happen if I set webgl.prefer_gl to true.

Updated

7 years ago
Summary: WebGL now Glitchy - worked better on beta 8 → WebGL now Glitchy with ANGLE - worked better on beta 8

Updated

7 years ago
Component: Graphics → Canvas: WebGL
QA Contact: thebes → canvas.webgl
The bodybrowser issue sounds like bug 621718 or at least dependent on it.
Notice that the webgl.prefer_gl preference has been renamed to webgl.prefer-native-gl. It also is now created (false) by default.

Also, today I have updated ANGLE to r550, so there's a nonzero chance that these issues with ANGLE will be solved in tomorrow's nightly build.
Please reopen if this is still an issue. I cannot test on WinXP, but this is WFM on Win7.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.