Last Comment Bug 625036 - Unable to use back and forward controls for totem player
: Unable to use back and forward controls for totem player
Status: RESOLVED INVALID
[4b9], [4rc]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 638777 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-12 06:11 PST by Srinivas
Modified: 2011-11-09 12:46 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Srinivas 2011-01-12 06:11:12 PST
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Unable to use back and forward controls for quicktime player

Reproducible: Always

Steps to Reproduce:
1.Load http://trailers.apple.com/trailers/fox/iceagecontinentaldrift/
2.Click watch now
3.a)Click on the left double arrow
b)click on right double arrow
Actual Results:  
A-The video does not get any variation


B-On clicking the left or right double arrows the pause button converts into play button(this button should appear when the video is paused) but the video is still playing

Expected Results:  
A-After step# 3.a)The video should go back to the beginning with 2x speed
  After step# 3.b)The video should go forward with 2x speed


B-The button should be in pause state only
Comment 1 Srinivas 2011-01-12 06:11:49 PST
QuickTime Plug-in 7.6.6
Comment 2 christian 2011-01-12 13:55:19 PST
I can't reproduce this on 10.6, 64bit. Also, this was filed on Linux...is that a mistake? There isn't QuickTime for Linux (https://addons.mozilla.org/en-US/firefox/browse/type:7)...from apple at least.
Comment 3 Srinivas 2011-01-12 21:32:41 PST
There is no quicktime player for Linux, but able to play the quicktime videos with libtotem plugin. 

about:plugins information 

QuickTime Plug-in 7.6.6

    File: libtotem-narrowspace-plugin.so
    Version: 
    The Totem 2.30.2 plugin handles video and audio streams.
Comment 4 George Carstoiu 2011-03-08 06:29:53 PST
*** Bug 638777 has been marked as a duplicate of this bug. ***
Comment 5 George Carstoiu 2011-03-08 06:31:17 PST
Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

Issue still present in RC1.
Comment 6 Karl Tomlinson (ni?:karlt) 2011-03-08 13:28:52 PST
Does creating a boolean pref "dom.ipc.plugins.enabled.libtotem-narrowspace-plugin.so" in about:config, and setting it to "false" work around the issue?

(libtotem-narrowspace-plugin.so is not an Xt plugin fwiw.)
Comment 7 Bastien Nocera 2011-11-08 15:17:47 PST
Pretty certain this has to do with:
void
totemPlugin::SetRate (double rate)
{
  // FIXMEchpe
}

which the site uses to control the playback speed. Srinivas, could you file a bug against Totem itself at http://bugzilla.gnome.org?
Comment 8 Bastien Nocera 2011-11-09 10:14:40 PST
Filed https://bugzilla.gnome.org/show_bug.cgi?id=663716
You can close this bug, it's not a Firefox bug.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-11-09 12:46:27 PST
Resolving INVALID since this is not a Firefox bug, as per comment 8.

Note You need to log in before you can comment on or make changes to this bug.