Closed Bug 625284 Opened 12 years ago Closed 12 years ago

Very high CPU usage on paper.smp.singtao.com

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(blocking2.0 -)

VERIFIED FIXED
Tracking Status
blocking2.0 --- -

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: regression)

Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101211
Firefox/4.0b8pre ID:20101211030333

Rrepoted on Forum
http://forums.mozillazine.org/viewtopic.php?p=10302629#p10302629

Very high CPU usage on paper.smp.singtao.com
CPU usage 30%-50%

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL ( http://paper.smp.singtao.com )
4. Wait till the page finishes completely loading


Actual Results:
 Very high CPU usage on paper.smp.singtao.com
 CPU usage 30%-50%

Expected Results:
 CPU usage should be 0%-10% (as of Firefox3.6.x)

Regression window(cached hourly):
Works:(CPU 0%-10%):
http://hg.mozilla.org/mozilla-central/rev/212a391d3b79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110052514
fails(CPU 30%-50%):
http://hg.mozilla.org/mozilla-central/rev/bdbef533364f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101109 Firefox/4.0b8pre ID:20101110081923
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=212a391d3b79&tochange=bdbef533364f
Blocks: 596451
Blocks: 583109
blocking2.0: --- → ?
Component: Layout → Plug-ins
QA Contact: layout → plugins
I wonder if bug 619176 helps with this.
I thought this bug mentioned scrolling, but is doesn't look like it, so the previous comment is probably not correct.
Which process has the high CPU usage? firefox.exe or plugin-container.exe? This is probably a dup of bug 612113.
plugin-container.exe is.
bug 612113 did not mention any regression range. so I do not know this is a dupe or not.
Unless this also causes noticeable lag or stuttering, I really don't think this needs to block. A profile might be nice, but since it will include Flash that might be a bit tricky.
blocking2.0: ? → -
Life of the battery of the laptop PC will become the problem
The problem seems to have been solved
Mozilla/5.0 (Windows NT 6.0; rv:2.0b11pre) Gecko/20110125 Firefox/4.0b11pre ID:20110125140611
Confirmed on
http://hg.mozilla.org/mozilla-central/rev/6a097e294828
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre ID:20110125030335
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.