If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Esc dismisses quick-filter-bar (threadpane) filter but keeps focus, input still in filter entry

RESOLVED FIXED in Thunderbird 8.0

Status

Thunderbird
Search
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: merike, Unassigned)

Tracking

Trunk
Thunderbird 8.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When you have a folder open with a selected message and quick filter toggled on then after escaping filter with CTRL+F to focus it and ESC to close the bar further input is still being processed.

In my case I wanted to untag a message when I noticed filter was on (as in the bar was visible with no conditions applied) and switched it off. Then I entered tag number and expected the message to be untagged. Instead quick filter processed that number and all but one email in the view was suddenly gone because no other mail matched this condition. I would expect that focus in email list should be restored after escaping the bar instead.

Comment 1

7 years ago
Possibly related to bug 571280 (similar focus issue).
Merike do you also see this wihout lightning ?
(Reporter)

Comment 3

7 years ago
Yes, I also see this with no addons enabled.
Duplicate of this bug: 641793
Summary: Quick search processes input after hiding it with escape → Esc dismisses quick-filter-bar (threadpane) filter but keeps focus, input still in filter entry
It looks like this is fixed in Nightly for Thunderbird 8, by the patch for bug 564328.  (The shortcut for Quick Filter has also changed to Ctrl+Shift+K.)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 564328
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
You need to log in before you can comment on or make changes to this bug.