text entry into forms is CPU intensive.

VERIFIED DUPLICATE of bug 58148

Status

()

Core
Layout: Form Controls
P1
major
VERIFIED DUPLICATE of bug 58148
18 years ago
17 years ago

People

(Reporter: Ben Woodard, Assigned: anthonyd)

Tracking

({helpwanted})

Trunk
mozilla0.9.2
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; m18) Gecko/20001209
BuildID:    cvs-12/10/00

For some reason, just entering text into a form ends up being CPU intensive.
This is quite noticable for me because my laptop has a fan in it that is off
most of the time but which kicks in when CPU utilization is high.

Reproducible: Always
Steps to Reproduce:
Type a bunch of text into the a form while running top.

Actual Results:  You will see that mozilla is using a huge amount of CPU while
just accepting keystrokes into a form.


Expected Results:  Keyboard input takes minimal CPU.

Comment 1

18 years ago
reassinging
Assignee: rods → beppe

Comment 2

18 years ago
*** Bug 62547 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
assigning to anthonyd and cc sfraser (to track for the embed work)
Assignee: beppe → anthonyd
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 4

18 years ago
well, this does happen.  i did a little testing (all on windows), here are the 
results:
typing in notepad: cpu hits 2%
typing in textfield on IE: cpu hits 11%
typing in textfield NOT in a table: cpu hits 50%
typing in textfield in a table: cpu hits 89%

really, really bad.  but we all know where the real problem here is, but ill 
wait to say it untill i have profile data to prove it yet again.

anthonyd
Severity: minor → major
Status: NEW → ASSIGNED
Priority: P3 → P1
(Reporter)

Comment 5

18 years ago
> we all know where the real problem here is

'cept me. I don't know what the real problem is. What is it? I'm curious. Is it
the code that takes the events for the windows and figures out what piece of
code actually needs to handle the event?

Comment 6

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire
(Assignee)

Comment 7

17 years ago
keeping this open for 0.9 because before buster left he checked in some layout 
code that will hopefully fix this.  His fix especially addresses the problem 
when in tables.

anthonyd (needing to re-test)
(Assignee)

Comment 8

17 years ago
setting platform and os to all, even though thhis was first reported on linux, 
it exists everywhere.

anthonyd
OS: Linux → All
Hardware: Other → All

Comment 9

17 years ago
moving this out to mozilla0.9.1 where we can spend a bit more time on this
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 10

17 years ago
Move this to mozilla0.9.2; anyone should feel free to help Tony out with this bug 
(unless he moves it back to 0.9.1).

Ben Woodard--do you still see the cpu hit?
Keywords: helpwanted
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

17 years ago
Blocks: 77421
I think this is a duplicate of bug 58148

Comment 12

17 years ago
Yup.


*** This bug has been marked as a duplicate of 58148 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.