Bug in Add-ons Manager - Will not open "Featured Add-ons"

VERIFIED FIXED in 5.12.6.*

Status

--
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: johngoodin, Assigned: cvan)

Tracking

unspecified
5.12.6.*
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre SeaMonkey/2.1b2pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre SeaMonkey/2.1b2pre

In the Add-ons Manager I select "Featured Add-ons" and "Adblock Plus".
Noting happens and I am returned to the top of the Get Add-ons page.

Reproducible: Always

Comment 1

8 years ago
When I do that the addons manager displays some information on Adblock Plus briefly but that disappears and all I see is a grey background with a box in the middle with the text:

"Add-ons are applications that let you personalize SeaMonkey with extra functionality or style. Try a time-saving sidebar, a weather notifier, or a themed look to make SeaMonkey your own."

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110114 SeaMonkey/2.1b2pre

With Minefield I see:

"Add-ons are applications that let you personalize Minefield with extra functionality or style. Try a time-saving sidebar, a weather notifier, or a themed look to make Minefield your own."

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre
Component: General → Add-ons Manager
Product: SeaMonkey → Toolkit
QA Contact: general → add-ons.manager
Version: unspecified → Trunk
Component: Add-ons Manager → Discovery Pane
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → discoverypane
Version: Trunk → unspecified
The add-on link is going to https://addons.mozilla.org/en-US/firefox/discovery/addon/adblock-plus/ (NOT services.amo) and the AOM does not like that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 5.12.6.*
Bug 615401 should have taken care of this.  Looks like we might need to let addon_list() know if it's on the disco pane or not.

Chris - let me know if you're around to work on this asap.  Otherwise I'll find someone else.
Assignee: nobody → cwiemeersch

Updated

8 years ago
Duplicate of this bug: 625837
(In reply to comment #1)
> When I do that the addons manager displays some information on Adblock Plus
> briefly but that disappears and all I see is a grey background with a box in
> the middle with the text

Just to mention, the fact that we briefly show the info before falling back to the general message is due to bug 602256
(Assignee)

Comment 6

8 years ago
Committed: https://github.com/jbalogh/zamboni/commit/6653f6
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Created attachment 504011 [details]
Post-fix screenshot
Verified FIXED on preview.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.