Last Comment Bug 626099 - Sync setup wizard: No space between links on manual sign in page
: Sync setup wizard: No space between links on manual sign in page
Status: RESOLVED FIXED
:
Product: Cloud Services
Classification: Client Software
Component: Firefox Sync: UI (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Philipp von Weitershausen [:philikon]
:
Mentors:
Depends on:
Blocks: 684536
  Show dependency treegraph
 
Reported: 2011-01-15 10:57 PST by u60234
Modified: 2011-09-14 04:01 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot (26.71 KB, image/png)
2011-01-15 10:57 PST, u60234
no flags Details
v1 (3.31 KB, patch)
2011-01-16 00:17 PST, Philipp von Weitershausen [:philikon]
mconnor: review-
Details | Diff | Splinter Review
v2 (3.96 KB, patch)
2011-01-18 20:34 PST, Philipp von Weitershausen [:philikon]
mconnor: review+
mconnor: approval2.0+
Details | Diff | Splinter Review

Description u60234 2011-01-15 10:57:08 PST
Created attachment 504149 [details]
screenshot

In bug 601019, two text links, "Show me how." and "I have lost my other device.", were placed together at the bottom of the "I don't have the device with me" Setup pane. However, there is no space between the two links. So unless the line with the two links are long enough to wrap and push the second link to a new line, they are joined together.

Steps to reproduce:
1. In the Sync Setup dialog, click "Connect" under "I already have a Firefox Sync account".
2. Click "I don't have the device with me".

Result:
Depending on platform and font size, I guess, the two links at the bottom can be joined together.
Comment 1 Philipp von Weitershausen [:philikon] 2011-01-15 20:20:05 PST
That teaches me not testing bug 601019 on Windows.
Comment 2 Philipp von Weitershausen [:philikon] 2011-01-16 00:17:35 PST
Created attachment 504222 [details] [diff] [review]
v1

Add a non-breaking space between the two labels. Because, of course, a regular space doesn't work. Or the copious amounts of whitespace that's around the labels already.

XUL, I swear, one of these days...
Comment 3 Philipp von Weitershausen [:philikon] 2011-01-16 00:18:27 PST
(In reply to comment #1)
> That teaches me not testing bug 601019 on Windows.

Btw, I remember now that I did test this on Windows 7... but like on OSX the label appears on the next line there.
Comment 4 Mike Connor [:mconnor] 2011-01-18 18:24:47 PST
Comment on attachment 504222 [details] [diff] [review]
v1

<spacer/> ? <separator/> ?

No strings for whitespace, especially now!
Comment 5 Philipp von Weitershausen [:philikon] 2011-01-18 18:48:08 PST
(In reply to comment #4)
> <spacer/> ? <separator/> ?

Hmm, for some reason I thought the kind of space would have to be l10n'able. Maybe I was overthinking this ;)
Comment 6 Philipp von Weitershausen [:philikon] 2011-01-18 20:34:32 PST
Created attachment 504980 [details] [diff] [review]
v2

Now with 100% less strings and 100% more <spacer/>s
Comment 7 Philipp von Weitershausen [:philikon] 2011-01-20 13:58:48 PST
http://hg.mozilla.org/mozilla-central/rev/696096dc3c8c

Note You need to log in before you can comment on or make changes to this bug.