The default bug view has changed. See this FAQ.

Sync setup wizard: No space between links on manual sign in page

RESOLVED FIXED

Status

Cloud Services
Firefox Sync: UI
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: u60234, Assigned: philikon)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 504149 [details]
screenshot

In bug 601019, two text links, "Show me how." and "I have lost my other device.", were placed together at the bottom of the "I don't have the device with me" Setup pane. However, there is no space between the two links. So unless the line with the two links are long enough to wrap and push the second link to a new line, they are joined together.

Steps to reproduce:
1. In the Sync Setup dialog, click "Connect" under "I already have a Firefox Sync account".
2. Click "I don't have the device with me".

Result:
Depending on platform and font size, I guess, the two links at the bottom can be joined together.
That teaches me not testing bug 601019 on Windows.
Assignee: nobody → philipp
Summary: No space between links on "I don't have the device with me" Setup pane → Sync setup wizard: No space between links on manual sign in page
Created attachment 504222 [details] [diff] [review]
v1

Add a non-breaking space between the two labels. Because, of course, a regular space doesn't work. Or the copious amounts of whitespace that's around the labels already.

XUL, I swear, one of these days...
Attachment #504222 - Flags: review?(mconnor)
Attachment #504222 - Flags: approval2.0?
(In reply to comment #1)
> That teaches me not testing bug 601019 on Windows.

Btw, I remember now that I did test this on Windows 7... but like on OSX the label appears on the next line there.
Comment on attachment 504222 [details] [diff] [review]
v1

<spacer/> ? <separator/> ?

No strings for whitespace, especially now!
Attachment #504222 - Flags: review?(mconnor)
Attachment #504222 - Flags: review-
Attachment #504222 - Flags: approval2.0?
(In reply to comment #4)
> <spacer/> ? <separator/> ?

Hmm, for some reason I thought the kind of space would have to be l10n'able. Maybe I was overthinking this ;)
Created attachment 504980 [details] [diff] [review]
v2

Now with 100% less strings and 100% more <spacer/>s
Attachment #504222 - Attachment is obsolete: true
Attachment #504980 - Flags: review?(mconnor)
Attachment #504980 - Flags: approval2.0?

Updated

6 years ago
Attachment #504980 - Flags: review?(mconnor)
Attachment #504980 - Flags: review+
Attachment #504980 - Flags: approval2.0?
Attachment #504980 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/696096dc3c8c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Blocks: 615950

Updated

6 years ago
Blocks: 684536

Updated

6 years ago
No longer blocks: 615950
You need to log in before you can comment on or make changes to this bug.