CSSStyleRule.selectorText does not return anything

VERIFIED DUPLICATE of bug 53448

Status

()

P3
normal
VERIFIED DUPLICATE of bug 53448
18 years ago
18 years ago

People

(Reporter: david, Assigned: jst)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
CSSStyleRule.selectorText doesn't work, as demonstrated by the code below

<head>
<style>
P { color: red }
</style>
</head>
<body>
<script>
var rule = document.styleSheets[0].cssRules[0];
// Bug: this should display "P { color: red }"
document.write("<p>rule.cssText: " + rule.cssText);

// Bug: this should display "P"
document.write("<p>rule.selectorText: " + rule.selectorText);

// Bug: this should return "color: red"
document.write("<p>rule.style.cssText: " + rule.style.cssText);

// Bug: this should work like calling item()
document.write("<p>rule.style[0]: " + rule.style[0]);

document.write("<p>rule.style.item(0): " + rule.style.item(0));
</script>
</body>
(Reporter)

Comment 1

18 years ago
See also bug #62607, bug #62612, bug #62613
Keywords: correctness
(Reporter)

Comment 2

18 years ago
Created attachment 20533 [details]
testcase
(Assignee)

Comment 3

18 years ago
This bug has been marked "future" because the original netscape engineer
workingon this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work in
some way -- please attach your concern to the bug for reconsideration.
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Future
dependency to 53448 added
Depends on: 53448
Fixed by patch solving 53448 ; the attached test case now works fine for
selectorText.

*** This bug has been marked as a duplicate of 53448 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Component: DOM Level 2 → DOM Style
Taking QA Contact on all open or unverified DOM Style bugs...
QA Contact: vidur → ian

Comment 7

18 years ago
VERIFIED dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.