Sound continues to play when closing tab group in panorama

RESOLVED WONTFIX

Status

defect
P3
normal
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: florian.neubauer.neuroscience, Unassigned)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Sound of youtube video (given web site is just an example, same happens on other youtube sites) continues to play when closing the tab group which contains that tab in panorama.

Reproducible: Always

Steps to Reproduce:
1. Go to e.g. http://www.youtube.com/watch?v=j50ZssEojtM
2. Video playing
3. Enter panorama
4. Close tab group which contains the tab of the video
5. Sound continues to play
Actual Results:  
Sound continues to play.

Expected Results:  
Sound stops playing.
Florian, does the audio stop when you click the close button on the "undo close group" button?
The sound stops when you click the close button on the "Undo Close Group" label

Updated

8 years ago
Blocks: 585689
Priority: -- → P3
Would be great to get this.
Blocks: 627096
No longer blocks: 585689
OS: Windows Vista → All
Hardware: x86 → All
Too late for this for Fx4. 

The real fix for this is to get rid of our "hidden" state for closed groups and actually close them for real and restore them via some new sessionstore "undo closed group" feature.

I suppose a more short-term fix would be to somehow go into those hidden tabs and tell flash to shut up, but that sounds difficult.
No longer blocks: 627096
Target Milestone: --- → Future
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.