Closed Bug 626618 Opened 9 years ago Closed 9 years ago

[d3d9] Graphics glitches on NVIDIA GeForce FX Go5200

Categories

(Core :: Graphics, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: aapo-bugzilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre

Various kinds of graphics glitches appear when I leave on GPU acceleration on my computer (old Dell Inspiron 8600 laptop, fully patched Windows XP SP3) with NVIDIA GeForce FX Go5200 chipset:

a) When a window is resized beyond certain size (something like 1000x1000), it will stop updating. Resizing the window back to any size below the threshold will make the window start updating again.

b) Text selection is laggy. The highlighted area will noticeably trail behind the pointer.

c) After using the browser for a while, some areas of content and chrome will randomly turn black. Sometimes they recover, sometimes not. Once this starts to happen, it will become more and more frequent until the browser is restarted, at which point the problem will go away for a while.

Turning hardware acceleration off (with layers.acceleration.disabled) will stop these problems from appearing. The drivers are the latest available (OEM driver pack from Dell, can't install directly from NVIDIA). Please see below for graphics information from about:support.

Reproducible: Always




about:support information

Adapter Description       NVIDIA GeForce FX Go5200
Vendor ID                 10de
Device ID                 0324
Adapter RAM               Unknown
Adapter Driver            snv4_disp
Driver Version            7.8.1.1
Driver Date
Direct2D Enabled          false
DirectWrite Enabled       false (0.0.0.0)
WebGL Renderer            NVIDIA Corporation -- GeForce FX Go5200/AGP/SSE2 -- 2.0.0
GPU Accelerated Windows   1/1 Direct3D 9
blocking2.0: --- → ?
The Geforce FX is early programmable hardware from 2003, with known shader performance issues.

http://en.wikipedia.org/wiki/GeForce_FX_Series#Overall_performance

anyway, we're implicitly going to be blacklisting it once we require newer NVIDIA drivers, since it's running on legacy drivers.
Blocks: 623338
Status: UNCONFIRMED → NEW
Ever confirmed: true
No longer blocks: 623338
Depends on: 623338
blocking2.0: ? → ---
The present bug is in principle fixed since GeForce FX are blacklisted (too old).

That bug 623876 is different: it's on a GeForce 7.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.