Web console's selection and copy functionality is broken on windows and linux

VERIFIED FIXED in Firefox 4.0b10

Status

defect
P2
normal
VERIFIED FIXED
9 years ago
Last year

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
Firefox 4.0b10
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [hardblocker])

Reporter

Description

9 years ago
STR:

1. Open web console on any web page, and cause something to be written to it (it doesn't matter what).
2. Select a line, right click, and select Copy.

Nothing happens.  The contents of the clipboard remain intact.  And no error gets reported to the error console either.

This seems to work on Mac at least...
Reporter

Updated

9 years ago
blocking2.0: --- → ?

Updated

9 years ago
Blocks: devtools4
Priority: -- → P2

Comment 1

9 years ago
(In reply to comment #0)
> This seems to work on Mac at least...

[I meant to file this yesterday but ran out of time]

On Windows, if I context click on an entry the selection turns from blue to grey and the nothing happens on the copy; But if I context click on the couple of pixels between entries then there is no problem with the copy.

In fact, if I click an entry it doesn't turn blue until I click in the gap.

Mozilla/5.0 (Windows NT 5.0; rv:2.0b10pre) Gecko/20110118 Firefox/4.0b10pre
Summary: Web console's copy functionality is busted on Ubuntu → Web console's copy functionality is busted

Comment 2

9 years ago
I can't follow the patches but bug 605621 (which is only half checked-in) and bug 613280 may be related.

Comment 3

9 years ago
Yes, it is possible that those are related. bug 605621 is expected to land in the next day or two (for beta 10).
Duplicate of this bug: 627007
this is happening on Linux and Windows. I'm doing some testing in Windows with the style patch applied to see how much of this it fixes. Hopefully all of it.
Summary: Web console's copy functionality is busted → Web console's selection and copy functionality is broken on windows and linux
Good news, everybody! A build with the remaining patch applied from bug 605621 does indeed fix the selection and copy issues in Windows and should improve Linux as well. Marking this bug as dependent.
Depends on: 605621
should be fixed by landing of bug 605621.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Reporter

Comment 8

9 years ago
Reopening because bug 605621 was backed out.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
and checked back in
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Still see the issue on build: 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre 

Is this landed yet?
it'll be in today's (01/20) build.
Target Milestone: --- → Firefox 4.0b10

Comment 12

9 years ago
Verifying that the Windows behaviour from comment #1 now seem OK; The order of multiple selections is odd but that is bug 626484.

Mozilla/5.0 (Windows NT 5.0; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre
blocking2.0: ? → final+
Whiteboard: [hardblocker]
verified as per comment #12
Status: RESOLVED → VERIFIED

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.