Last Comment Bug 626716 - Remove VC7.1 support code
: Remove VC7.1 support code
Status: RESOLVED FIXED
[fixed-in-nanojit][fixed-in-tracemonkey]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on: post2.0 610936
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-18 11:20 PST by neil@parkwaycc.co.uk
Modified: 2011-04-26 15:40 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (5.29 KB, patch)
2011-01-18 11:23 PST, neil@parkwaycc.co.uk
n.nethercote: review+
edwsmith: review+
Details | Diff | Review
Remove use of NJ_NO_VARIADIC_MACROS from Tamarin (866 bytes, patch)
2011-01-28 07:45 PST, Edwin Smith
rreitmai: review+
Details | Diff | Review
Remainder of patch for check in (2.10 KB, patch)
2011-04-13 13:36 PDT, neil@parkwaycc.co.uk
no flags Details | Diff | Review

Description neil@parkwaycc.co.uk 2011-01-18 11:20:37 PST
Support for VC7.1 (and VC8 without service pack) was dropped in bug 610936.

Some code which was added to support VC7.1 for Firefox 3.5 can now be removed.
Comment 1 neil@parkwaycc.co.uk 2011-01-18 11:23:36 PST
Created attachment 504787 [details] [diff] [review]
Proposed patch
Comment 2 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-01-18 12:37:57 PST
Comment on attachment 504787 [details] [diff] [review]
Proposed patch

Nanojit is shared with Adobe, so I'm asking Ed to review this as well.

Neil, the check-in procedure for Nanojit is also non-standard.  See https://developer.mozilla.org/en/NanojitMerge for details.
Comment 3 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-01-18 16:18:50 PST
Comment on attachment 504787 [details] [diff] [review]
Proposed patch

The TM-specific (non-nanojit) parts look fine to me.  We'll need Ed to confirm whether the nanojit changes are acceptable to Adobe.
Comment 4 Edwin Smith 2011-01-19 17:04:37 PST
On the surface, I think we still support at least one broken compiler that doesn't understand varadic macros (Symbian).  I will double check and follow up.
Comment 5 Edwin Smith 2011-01-28 07:45:15 PST
Created attachment 507860 [details] [diff] [review]
Remove use of NJ_NO_VARIADIC_MACROS from Tamarin

This is the tamarin-redux part.
Comment 6 neil@parkwaycc.co.uk 2011-02-23 06:46:32 PST
Pushed changeset 7f482bf4ca5a to nanojit-central.
Comment 7 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-03-02 21:48:09 PST
http://hg.mozilla.org/tracemonkey/rev/7d3160757f82

Reopening, because it hasn't been merged everywhere yet.
Comment 8 Chris Leary [:cdleary] (not checking bugmail) 2011-03-31 14:43:29 PDT
http://hg.mozilla.org/mozilla-central/rev/7d3160757f82
Comment 9 neil@parkwaycc.co.uk 2011-04-13 12:03:19 PDT
Reopening, because only the nanojit portions have landed.
Comment 10 neil@parkwaycc.co.uk 2011-04-13 13:36:37 PDT
Created attachment 525789 [details] [diff] [review]
Remainder of patch for check in
Comment 11 Jeff Walden [:Waldo] (remove +bmo to email) 2011-04-14 12:58:02 PDT
http://hg.mozilla.org/tracemonkey/rev/b42dc3bee7a6
Comment 12 Mounir Lamouri (:mounir) 2011-04-20 12:59:56 PDT
I believe it doesn't need to be marked as checkin-needed given that it's now in tracemonkey.
Comment 13 Chris Leary [:cdleary] (not checking bugmail) 2011-04-26 15:40:33 PDT
http://hg.mozilla.org/mozilla-central/rev/b42dc3bee7a6

Note You need to log in before you can comment on or make changes to this bug.