Adblock Plus ABP three times the memory overhead in FF 4 vs 3.6

RESOLVED INCOMPLETE

Status

()

Core
JavaScript Engine
RESOLVED INCOMPLETE
7 years ago
4 years ago

People

(Reporter: orangezilla, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Adblock Plus (ABP) adds around 24MB extra memory in Firefox 4 Beta 9 vs all addons being disabled, compared to only around 8MB in Firefox 3.6.

Reproducible: Always

Steps to Reproduce:
1. Manually disable all addons or Help>Restart with Addons disabled
2. Wait 10-15 seconds for CPU cycling of Firefox.exe to die down, then note
down memory usage using about:memory or Process Explorer.
3.Enable Adblock Plus addon, wait 10-15 seconds, and note down memory as before, repeat with Firefox 3.6.


Actual Results:  
Firefox 4 Beta 9

5 tabs all addons disabled 91.5MB

5 tabs + ABP 115.7MB

Firefox 3.6.13

10 tabs all addons disabled 66.5MB 
10 tabs + ABP 75.1MB 



Expected Results:  
Memory overhead of Adblockplus should be similar in Firefox 4 as in 3.6
The developers are currently working in that area, bug 623428 is an example.
I'm moving this to JS Engine because it's most likely the cause of more used memory but the report itself might be to unspecific.
Assignee: nobody → general
Component: Extension Compatibility → JavaScript Engine
Product: Firefox → Core
QA Contact: extension.compatibility → general
Version: unspecified → Trunk
orangezilla, can you look at the about:memory results, before and after enabling ABP, and get an idea of where the increase(s) are occurring?
(Reporter)

Comment 3

7 years ago
Ah sorry guys, looks like somewhat of a false alarm on this one, I was under the impression that disabling addons through safe mode pretty much had the same effect as manually disabling them all, but after running all the tests again with about:memory, I can see that in safe mode js/mjit-code is always zero- I assume this is methodjit- jaegermonkey, that is disabled in safe mode? If so it looks like there is only an 8-10MB difference in private bytes usage between all addons disabled manually (with methodjit enabled) and having the Adblock Plus extension enabled which isn't much difference to the memory overhead of ABP in 3.6. There is a definite problem with with Mozilla Labs feedback addon though, it is adding 55MB upwards of additional private bytes usage vs all addons disabled manually (jaegermonkey enabled, hardware acceleration disabled) see https://bugzilla.mozilla.org/show_bug.cgi?id=626785
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 4

7 years ago
Yeah, Safe Mode disables JaegerMonkey.
The safemode disables all extensions, JM/TM and hardware acceleration.
orangezilla, thanks for doing the extra testing and working this out.
(Reporter)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 7

7 years ago
Don't know if about:memory was somehow skewing the test on 4b9 or just half asleep here, but did the test firstly with process explorer in the latest 10pre nightly, and then with about:memory and there was a definite 20-24MB increase between disabling all addons manually (NOT safe mode) and enabling Adblock Plus with Easylist USA subscription, see my latest posts here
http://forums.mozillazine.org/viewtopic.php?f=23&t=2076797&p=10337357#p10337357
(Reporter)

Comment 8

7 years ago
May be a general issue of increased memory usage by addons in 4, i.e. with an example of 3 addons, Click & Clean, FireGestures & PrefBar, FF4 b10Pre used 14.22MB private bytes vs 1.68MB private bytes in 3.6.13

http://forums.mozillazine.org/viewtopic.php?f=23&t=2076797&p=10339829#p10339829

Comment 9

5 years ago
orangezilla, 
What is your current thinking about comment 8?
And, do you still see this?
Flags: needinfo?(orangezilla)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago4 years ago
Flags: needinfo?(orangezilla)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.