add-on validation claims a javascript syntax error when there isn't one

VERIFIED FIXED in 5.12.7

Status

P3
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: als, Assigned: basta)

Tracking

unspecified
5.12.7

Details

(Whiteboard: [validator], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 

This warning has been present for every version of the add-on. The add-on runs fine.

Reproducible: Always

Steps to Reproduce:
1.validate the add-on
2.
3.
Actual Results:  
JavaScript Syntax Error

Warning: A syntax error in the JavaScript halted validation of that file.

Warning: Message: missing ; before statement
chrome/blacken.jar/chrome/content/blacken.js

1
2
3 r gBlacken = {

Expected Results:  
Line 3 actually has "var gBlacken = {"
Perhaps the garbled report is part of the problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P3
Hardware: x86 → All
Target Milestone: --- → 5.12.7

Updated

8 years ago
Assignee: nobody → mbasta
Created attachment 505443 [details]
blacken-1.4.3-fx.xpi
(Assignee)

Comment 2

8 years ago
Fixed:

https://github.com/mattbasta/amo-validator/commit/89832f6c9d04fd1e9513b67e0c4405844574848a

The problem was related: while attempting to remove BOMs (which can break cssutils), too many characters were being stripped. This is fixed now using the new textfilter module that I built for the JS tests.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 3

8 years ago
No JS errors on uploading the attached test file. Marking this as verified @ https://addons.allizom.org/en-US/developers/upload/1dea078604284dcebe5294f18137563d
Status: RESOLVED → VERIFIED
Whiteboard: [validator]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.